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Introduction
Welcome to Buzzword, the first real word processor for the web. Buzzword makes it easy for you to create a document 

from any computer on the Web, share it with colleagues, and review and revise it as a team. 

Buzzword works on any PC or Macintosh that is connected to the Internet and running Adobe's Flash Player. 

Buzzword runs from Virtual Ubiquity's secure servers, and your documents are stored there, so they are ... well, 

ubiquitous: always available on the Web. And always securely private, except from the people you invite to share 

them.

You'll soon find that Buzzword offers a distinct alternative to traditional word processors. For one thing, you do not 

have to install the product. For another, you'll be able to use Buzzword on any computer that is connected to the 

Internet and have your word processor and your files at your fingertips.

A third difference is that you'll find it easy and convenient to share documents with friends and colleagues without 

having to use email attachments. Because we store your documents on our secure servers, all you need to do is invite 

someone to share your document and you'll both have access.

mailTo:feedback@buzzword.com



Buzzword runs on any computer with Flash Player 9 that is running IE 6 or 7, Safari 2, Safari 3 (Macintosh only), or 

Firefox. This means that you can use Macintosh or Windows computers interchangeably. For example, you could start 

an essay at home on your iBook, go to the school library and work on it using a Windows machine, and then share it 

with a friend who uses either platform. You'll have the same file and the same product regardless of the platform you 

choose.

Note on Buzzword Preview Documentation
This Help is a preliminary form of our documentation. It will be refined and enhanced periodically to accommodate 

feedback from users, as well as to reflect new Buzzword capabilities. We welcome any feedback from you at 

feedback@buzzword.com.



Menus
Menus
Buzzword Menu
The Buzzword menu contains the following commands:

• About Buzzword

• Settings & Preferences...

• Privacy Policy

• Terms of Service

• Sign Out

About Buzzword

The About Buzzword dialog box lists credits for the team that created the product. It also includes a version number 

and copyright notices for the spelling technology used in Buzzword.

Settings & Preferences

The Settings & Preferences dialog box allows you to manage account settings and set preferences. You can change 

the way your name appears, your email address, or your password. You can add an image to accompany your name 

on the Collaboration bar at the bottom of the screen and in the heading of lists by author. You can also choose which 

unit of measurement to use and whether to have misspelled words flagged as you type.

• Your name: Enter the name that you want to appear to others when you share documents with them, and 

when you add comments to a document.

• Your email: Enter the address you use (with your password) to sign in to Buzzword, and that others use when 

inviting you to share.

• Password: Enter at least 6 characters that include at least one number and at least one letter.

• Your image: You can upload any BMP, JPEG, JPG, GIF, PNG, or TIFF image no larger than 8MB. Click 

Change to upload the image from your computer; click Clear to have the default Buzzword image appear.

• Units of measurement: Specify inches, centimeters, or points as the measurement that will be used on all 

your documents. The unit you choose will appear on the ruler in every document you create, and in the Page 

Setup dialog box, where you can specify margins.

• Spelling: Choose whether to have misspelled words underscored in red as you type. Also, add words that the 

spelling checker may flag that are spelled correctly, such as technical terms, people's names, and so on. 

Click “Edit word list” to make changes to your custom word list. Type a word in the box and click OK to add it. 

Buzzword automatically alphabetizes the list.
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Privacy Policy

This option takes you to the Privacy Policy on the Buzzword Web site, which describes how information that is 

collected about you is used and safeguarded.

Terms of Service

This option takes you to the Terms of Service on the Buzzword Web site, which outline the conditions for using 

Buzzword, such as age requirement and legal responsibilities.

Sign Out

The Sign Out menu option signs you out of Buzzword, and returns you to the Sign In screen.

http://www.buzzword.com/help/index.html#docOrganizer


Document Menu

Document Menu
When you have a document open, the Document menu contains the following commands:

• New

• Open

• Close

• Save

• Save As...

• Share...

• Page Setup...

• Print...

When you view a listing of your documents in the Document Organizer, other commands are available.

New
You can start a new document while you are still working on an open document. Click New and another window or tab 

opens, with a blank document.

Open...
You can open a document while you are still editing another document. Open... displays the Document Organizer in a 

new window or a new tab, where you can select another document, have both documents open at the same time, and 

move between them.

Close
When you are finished working on a document, click Close to go to the Document Organizer. 

Save

Note: You can also close your document by clicking the Docs icon on the right side of the toolbar.



You can use the Save command to explicitly save your document on the Buzzword server. Buzzword automatically 

saves changes to an active document at intervals based on time and level of activity, but the Save command allows 

you to save your document without waiting.

Save As...
The Save As command creates a new instance of the current document with a new name; it also lets you export 

documents to Microsoft Word (.doc), Microsoft Word 2003 XML (.xml), Microsoft Word 2007 (.docx), Rich Text Format 

(.rtf), HTML zipped into a compressed file (.zip), or plain text (.txt) files.

To save a Buzzword document with a new name:

1. With the document open, click Document, Save As...

2. By default, the Type option is “Buzzword document.”

3. Enter a name; by default, the name is the same, with the word copy appended; for example, your copy of 

"Notes for Thesis" would be named "Notes for Thesis copy." You can of course change this.

4. Click OK.

Notes:

• When you save a document under a new name, regardless of your privilege level, or role (author, co-author, 

reviewer, or reader), on the original document, you are the author of the newly created document.

• The new document retains comments from the original version. However, the new document does not include 

collaborators from the original document — you have to add them explicitly.

• The new document does not retain the version history of the original document.

• Changes to the new document do not affect the original document.

To export a Buzzword document:

Note: Your browser may allow you to specify a particular location for saving all downloads or it may always open a 

dialog box that asks you whether to open the document or save it. It may also specify an application for opening the 

document.

1. With the document open, click Document, Save As...

Note: Another way to explicitly save your document is to click the Synchronator in the lower 
right corner of the Buzzword screen.
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2. Next to Type, click the File button.

3. Select the type of file from the drop-down list and click OK.

4. If you have specified a location for your browser to save downloaded files, the file is saved there. If not, the 

usual browser dialog box appears, asking you where you want to save this file.

1. The Save As... dialog box opens, allowing you to browse for a location.

2. Navigate to the location you want and click Save.

Note: The file will have the same name as in Buzzword, except that spaces will be replaced with underscores. For 

example, “Notes for Thesis” would be saved as “Notes_for_Thesis.”

Fonts that Buzzword uses are mapped as follows:

• Adobe Garamond Pro to Georgia

• Courier Std to Courier New

• Cronos Pro to Trebuchet

• Minion Pro to Times New Roman

• Myriad Pro to Arial

• News Gothic Std to Lucida Sans Unicode

• Tekton Pro to Comic Sans MS

Note: In the Preview release, exported images that float with center or right alignment and an offset do not retain the 

offset in the resulting document, so if you have used these layout options, the exported document's layout may be 

different from the layout in Buzzword.

Share...
The Share dialog box lets you share a document by sending an email invitation. For people who already have 

Buzzword accounts, you can just assign the new collaborator a role: Co-Author, Reviewer, or Reader For more details 

about sharing, see Sharing Documents.

Page Setup...
The Page Setup dialog box allows you to specify margins and paper size. The units of measurement (inches, 

centimeters, or points) are set in Settings & Preferences, on the Buzzword menu. Page Setup also allows you to 

specify a different header and/or footer on the first page of the document.

Page Setup values are set only for the document you are working on. There is currently no way to save different 

default settings that you can apply to all your documents.
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Print...
The Print command sends your document to the printer exactly as it's laid out on the screen, except for comments, 

which appear at the end of the printed document, beginning on a new page.

After choosing Document Print, you see a print dialog box that lets you specify paper size and orientation; select which 

pages to print; and turn printing comments on or off. Once you click OK, you see your usual operating system print 

dialog box where you can select the destination printer.

When the document prints, any comments appear at the end of the document, following the endnotes, if any. 

Comments are listed in the same order as they appear in the document itself, numbered to match the boxed reference 

numbers that appear in the right margin of the printed document, next to the text to which the comment applies. 

Identifying information — commenter's name, date and time of comment — follows each comment.

Note: For Macintosh users, when you print in Buzzword, an additional dialog box appears, as shown below.

http://www.buzzword.com/help/index.html#sharing




Edit Menu

Edit Menu
The Edit menu contains familiar commands, including the following:

• Undo / Redo

• Cut / Copy / Paste

• Delete

• Find

• Check Spelling

• Select All

Undo
You can reverse any editing action by selecting the Undo command from the Edit menu. Buzzword keeps track of the 

last 100 changes you’ve made to the document, so you can invoke the Undo command as many times as you need to 

return to just about any point in your editing session.

You can invoke the Undo command from the Edit menu, or by pressing Ctrl-Z ( -Z on Safari).

Redo
If you have used Undo, but change your mind and want to reverse the Undo action, select the Redo command from the 

Edit menu. Redo works exactly the same as Undo except that it goes forward through your edits instead of backward.

You can invoke the Redo command from the Edit menu, or by pressing Ctrl-Y ( -Y on Safari).

Cut / Copy / Paste
The Cut, Copy, and Paste commands function as with any word processor. Inside Buzzword they work with all text, 

tables, or images, or all three in one selection.

However, when you paste something that you have copied from outside Buzzword, although you can copy and paste 

text or tables from any document, you can copy and paste images only from Web sites. You cannot copy images from 

desktop applications, such as Microsoft Word or PDF files, and paste them into Buzzword documents.

Also, always check for copyright restrictions when you copy from Web sites.

Note: Depending on the security settings at the Web site, you may be prevented from copying an image.

You can invoke these commands from the Edit menu, or you can use the following keyboard shortcuts:

Command Windows (IE and 
Firefox)

Mac (Firefox and 
Safari)

http://www.buzzword.com/help/index.html#insertFieldMenu


When you copy an image from a Web site, highlight the image to select it, then use the keyboard command to copy it. 

Then use the keyboard command to paste the image into the Buzzword document.

Note: When you copy and paste images using Edit commands, you can copy many images at a time and paste them 

all into the document. Buzzword gives you a progress report on how many images have been pasted. If Buzzword 

cannot paste all the images, Buzzword indicates how many images have successfully pasted. If you cancel a paste 

operation partway through it, or the connection is dropped, Buzzword only counts the images pasted before the 

cancellation, and indicates how many in that sequence were not pasted for some other reason.

Delete
Delete removes the current selection, which can include text, images, tables, or all three kinds of entries.

Find & Replace
To use the Find & Replace commands, open the Find toolbar by selecting Find from the Edit menu or by using the 

shortcut Ctrl-F ( -F on Safari). To dismiss this toolbar, click on the x at the far left.

The Find command searches the document body, including any endnotes, but does not search comments, headers, or 

footers.

You cannot use Find to look for special characters such as:

• Paragraph mark

• Tab character

• Manual line break

• Manual page break

• Field marker

Other Find Settings

You can refine your search by clicking the menu button  (the down arrow to the right of the Previous button) for the 

following settings:

• Match case: Buzzword only finds text that exactly matches the uppercase and lowercase characters in the 

Find box.

Cut: Ctrl-X -X
Copy: Ctrl-C -C
Paste: Ctrl-V -V



• Whole word only: Buzzword finds only complete words that match the text in the Find box. Complete words 

are surrounded by spaces, periods, punctuation marks, or non-printing characters such as paragraph breaks.

For example, if you want to search for every instance of “cat” regardless of whether it is capitalized or not, leave Match 

Case unchecked. If you only want to find “Cat” but not “cat” specify “Cat” in the Find box and check Match Case.

Whole word only is useful if you want to find all occurrences of “cat” but do not want to find “cat” in “caterpillar.”

Find searches from where you start to the end or to the beginning of the document, depending on whether you click 

Next or Previous. When there are no more occurrences to be found in that direction, a message appears under the 

Find box: “Buzzword has reached the end of the document.” or “Buzzword has reached the beginning of the 

document.”

To continue the search at this point, click Next or Previous again. Buzzword continues the search from the beginning 

(or end) of the document.

If there is no exact match to your search criteria, a similar message appears below the Find box: “Buzzword has 

reached the end of the document.”

The Replace box replaces the found words with the word specified in the Replace box. You can replace words one at 

a time, or use Replace All to do it all at once. When you use the Replace All option, a message tells you how many 

replacements occurred.

Check Spelling
Note: Check Spelling is available only to authors and co-authors of a document.

As you type, Buzzword checks your spelling. Words that are not recognized are marked with a dotted red underline.

At the same time, a counter in the lower right corner keeps track of the number of questionable words, identified as 

“flagged” words.



If you notice a flagged word as you go through the document, you can move your mouse over the word and click on the 

red underline to display a list of choices. 

You have three choices:

• Specify that your spelling is correct by clicking “word is OK always.”

• Accept the existing spelling in only the current document by clicking “word is OK in this document.”

• Select the correct spelling from the list of suggested spellings.

If none of these options is appropriate, you can correct the actual text yourself.

All instances of the spelling you have just selected will be accepted throughout the document. If you specify that your 

original spelling is correct, the word is also added to your custom word list and accepted in every document you create 

from then on. If you specify that the word is acceptable only in this document, the underline will be removed and the 

word will be accepted only in that document. In both cases, in this document the spelling will be accepted as correct no 

matter who opens it, you or a co-author.

When you correct a flagged word after you have clicked on it, the word will be highlighted when you finish; however, if 

you select Check Spelling from the Edit menu, you automatically move to the next flagged word. (If you want to stop 

checking spelling before the entire document is reviewed, just click anywhere in the document.)

When you first open a shared document, there may be a brief delay in removing the underline from words that have 

been accepted. When another user has control of the document (each collaborator has control of the document when 

actually editing it), newly accepted words cannot be checked.

Spell checking ignores the following kinds of words:

• Words that contain numbers, such as 2007, W3

• Words that are all uppercase, such as PTO, ASCAP

• Words that consist of only one letter

Spell checking checks the following kinds of capitalization:

• Words that require capitals, such as Friday, British, Mozart, are flagged if they are not capitalized.



• Words that include capitals, such as iPhone, PostScript, rEady, are flagged. You can always add a word that 

is properly spelled with an inside capital to your word list.

• Words that have been added to the word list as capitalized. For example, if you add “friend” to your word list, 

Buzzword will accept both “friend” and “Friend,” but if you add “Friend,” Buzzword will only accept “Friend.”

Spell checking does not check headers, footers, or comments.

Note: In the Preview release, spell checking uses only the rules of U.S. English. In upcoming releases, this feature will 

be expanded to include other languages.

Select All

To select the entire document, use Select All from the Edit menu, or Ctrl-A ( -A on Safari). You can then use Cut, 

Copy, Paste, or Delete, or change any of the settings on the Font or Paragraph toolbars.



Insert menu

Insert Menu
Insert Table
To insert a table into a document, select Table from the Insert menu. (You can also use the toolbar.) Buzzword inserts 

a table with two rows and two columns. For more information on creating tables, go to Table Toolbar.

Insert Image...
To insert an image into a document, select the Insert Image command. (You can also use the toolbar.) For more 

information on working with images, go to Image Toolbar.

Insert Endnote
You can annotate your text with references, such as attributions, citations, and detailed discussions not suitable for 

inclusion in the text itself. Because these supplementary notes appear at the end of the document, Buzzword refers to 

them as “endnotes”; you may be more accustomed to seeing them as footnotes at the bottom of a page.

To insert an endnote, place your cursor at the point in the document where you want the reference to the endnote to 

appear; that is, at the end of the passage further identified in the endnote. Choose the Insert Endnote command. (If 

you select text and insert an endnote, the selected text will be replaced. It will not be underlined, as it is when you add 

a comment about selected text.)

A bracketed number, the reference mark, appears in your text and at the end of the document; your document 

immediately scrolls to this point, where you enter the text for the note.

The endnotes themselves appear beginning on the last page of the text of the document. If you would like them to 

appear starting on a new page, insert a page break at the end of your document.

As you continue to create endnotes, reference numbers are automatically numbered according to the order in which 

they appear in the document. This means that you can enter an endnote at the beginning of the document and all the 

reference numbers and corresponding numbers in the endnotes that follow are automatically incremented by one. 

Similarly, when you delete an endnote, all the endnotes that follow it are renumbered.

Note: Do not delete the reference number in the text; this will delete the entire endnote.

You can copy an endnote by copying the reference mark and inserting it at the relevant points in the text. The 

reference numbers will update automatically, and a new endnote will appear in the appropriate place in the list of 

endnotes at the end of the document. If there are differences among the endnotes, such as references to specific page 

numbers in the work you are citing, you can edit each endnote.

You can navigate from the text to the endnote that annotates it and from the endnote to the text. As you move your 

mouse over a reference mark, the mark is highlighted. Click on the reference mark to go to the linked endnote or text. 

If you are navigating from an endnote to its linked text, the cursor will appear right before the reference mark in the 

text.



Insert Comment
To insert a comment about the currently selected document text, choose the Insert Comment command. You can also 

insert a comment by clicking in the new comment bubble , which is in the right margin on the same line as the 

cursor. For more information on comments, go to Working with Comments.

Insert Link...
You can enrich your Buzzword documents by creating a variety of links: links to other Web sites, mail-to links to email 

addresses, links to FTP sites.

Note: You can also create useful connections between Buzzword documents by inserting a link from one — or more 

— documents in another. You can email a link to a Buzzword document, or send it in an instant message, or post it in 

a blog or on your own Web site. You must share any document you link to with your readers. When the reader clicks 

the link to a Buzzword document, he or she is asked to sign in before opening the document. See Sharing Documents 

for details.

To create a link in a Buzzword document, follow these simple steps:

1. In the Buzzword document, put the cursor where you want the link to appear, or select text that you want to 

use to label the link. 

Note: You cannot use an image as a link.

2. Choose Link... from the Insert menu. The Insert Link dialog box appears.

Notice that any text you selected appears in the “Link text” box. If you do not first select text for a label, you 

must type something in the “Link text” box.

3. Type or paste the URL, using Ctrl-V or -V, into the “Link URL” text box.

4. Click OK.

The link will now appear in your document, and clicking on it will open the page or document you linked to.

To edit a link, move your mouse cursor over it. A tooltip will appear telling you how to edit the link text or the URL.

Insert Header/Insert Footer...



Use Insert Header and Insert Footer to create and specify headers and footers. When you select Insert Header or 

Insert Footer, the Insert Header or Insert Footer dialog box opens. Use the options to specify the header or footer 

information.

Alternatively, you can double-click on the top margin of the page to open the header dialog box, or on the bottom 

margin to open the footer dialog. If no header or footer exists, the appropriate dialog box opens. If a header or footer 

already exists, you can edit the header or footer directly.

Headers and footers automatically set a left-aligned region, a center tab stop, and a right tab stop so that text appears 

at the margins and centered on the page. If you change the page dimensions, you may need to adjust these tab 

settings.

When you first open the header dialog box, a header is supplied; similarly, the footer dialog box already contains a 

default footer. Both use fields that are available from the Insert menu. The Insert Header dialog box automatically 

supplies the page number as the center segment; Insert Footer supplies Date Last Saved in the center. For 

information about the fields that are available for headers and footers, see Insert Field.

Note: If you create a header or footer and then delete all the text, Buzzword retains an empty header or footer. To add 

text to an empty header or footer, just click in the area and type.

Any change you make to a header or footer is reflected in the header or footer for all pages in the document. The only 

exception is that the first page header or footer can be different from the ones on the following pages. To make a first 

page header or footer unique, click the check box next to “Insert a different header (footer) on the first page of the 

document” in the Header/Footer dialog box.

Text in a header or footer can be formatted, just like any other text in the document.

Insert Page Break
To insert a page break, choose the Insert Page Break command. This command forces a page break and places the 

next character at the beginning of the next page. Ctrl-Enter is the shortcut.

Insert Line Break
To move text at the cursor, or insertion point, down one line while keeping it part of the current paragraph, choose the 

Insert Line Break command. This command forces a line break and places the character following the line break at the 

beginning of the next line. Shift-Enter is the shortcut.

Insert Special Characters...
Characters that are not on most keyboards are available through this command, such as:

• Characters from non-English languages, such as the letter “u” with an umlaut (ü), the acute accent (é) over 

the letter “e,” and so on — 

Currently Buzzword does not provide characters from alphabets other than the Latin alphabet, such as 

Arabic, Cyrillic, Greek, or Hebrew, or from ideographic languages, such as Chinese.

• Fractions and symbols such as currency symbols



• Non-English punctuation and other punctuation that does not appear on the keyboard, such as the em-dash 

(—)

When you select Special Characters... from the Insert menu, the Special Characters dialog box appears:

  

  
At the top of the box is a drop-down menu of fonts, showing the font that you are using. You can change to a different 

font if the special character you want is not in your current font, or if you want the character to appear in a different font.

On the next line is a row of boxes, each representing a different category of special character:

To insert a special character: 

1. If necessary, click on the box for the type of character you want.

2. Move your mouse over the characters and click on the one you want.

3. If you want to insert another special character, repeat the preceding steps. The Special Characters dialog box 

remains on the screen until you close it by clicking the cancel symbol in the upper right corner.

Non-English characters

Numbers and symbols

Punctuation

Alphabetic characters



Notice that you can move the Special Characters dialog box wherever you want, so that you can see the result of your 

insertion. You can leave the Special Characters dialog open during your entire editing session; this is convenient when 

you are using special characters throughout a document.

Insert Field
Fields are a way to insert “computed” text into a document. A field automatically updates its value without you having 

to change it explicitly.

For the Preview release, Buzzword includes the following fields:

• Document Name

• Document Author

• Date Last Saved

• Page Number

• Number of Pages

Page Number and Number of Pages fields can only be inserted in headers and footers — the others can be placed 

anywhere in your document.

Note: You can combine two fields in a header or footer. For example, you can combine text and fields to produce a 

footer that reads “Page 7 of 9.” To do this, you insert Page Number, then click in the header or footer where you have 

inserted it, type the word “of,” then select Number of Pages from the Insert Field dialog box.
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