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Working with the BtoCAD Explorer 

The BtoCAD Explorer provides a powerful and convenient way to maintain and manage many of the features 
and settings of your drawings. You can use the BtoCAD Explorer to work with layers, linetypes, text styles, 
coordinate systems, named views, blocks, and dimension styles within the current drawing or to copy this 
information between drawings. 
 
This section explains how to use the BtoCAD Explorer to: 
 

•   Manage elements related to settings and entities in your drawings. 
•   Organize information on layers and manage layers. 
•   Create and use linetypes. 
•   Load text fonts and create text styles. 
•   Select and control coordinate systems. 
•   Save and restore named views. 
•   Save, insert, and manage blocks. 
•   Copy, cut, and paste dimension styles between DWG files. 
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Using the BtoCAD Explorer 

The BtoCAD Explorer opens in its own, separate window, which you can move or resize. The BtoCAD Explorer 
window has its own menu and tools. 
 
To display the BtoCAD Explorer 
Do one of the following: 

• Choose Tools > Explore Coordinate Systems. 
• 

On the Tools toolbar, click the BtoCAD Explorer tool  
• Type explayers and then press Enter. 
• Type la and then press Enter. 

•   On the status bar, right-click on the current layer, and from the list, select the layer you want to make 
current. 
 
The BtoCAD Explorer window has two panes, a left pane and a right pane. The elements are listed in the left 
pane, and the drawing settings are listed and described in the right pane. 
 
TIP On the Settings menu, you can use the Explore Layers, Explore Blocks, Explore Views, Explore Coordinate 
Systems, Explore Linetypes, Explore Text Styles, and Explore Dimension Styles commands to display the layers, 
blocks, views, coordinate systems, linetypes, text styles, and dimension styles for the current drawing in the 
BtoCAD Explorer window. Tools for these commands also appear on the Settings toolbar. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A  Tools on the Standard toolbar provide controls common to all elements. 
B  The Elements pane shows an outline view containing the name of every drawing currently open and lists the elements you 

can control in each drawing. 
C   Click on a setting to change it. 
D  The named settings for the selected element. 
E  Other toolbars appear, depending on the selection in the Elements pane. 
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Using the BtoCAD Explorer, you can create, delete, or modify any of the settings for the currently selected 
element for a given drawing. You can also copy the contents of any element from one drawing to another. The 
tools and menu items on the BtoCAD Explorer provide the following functions: 
 
IntelliCAD Explorer tools 
                                   Tool                  Function 
 

) New Item Creates a new layer, linetype, style, coordinate system, view, 
block, or dimension style. 

 
) Current Makes the selection current. 

 
) Cut Cuts the selection to the Clipboard. 

 
) Copy Copies the selection to the Clipboard. 

 
) Paste Pastes the selection from the Clipboard into the appropriate list 

of a different drawing. 
 

) Delete Deletes the selection from the list. 
 

) Properties Displays the properties for the selection. 
 

) World Sets the current coordinate system to the World Coordinate 
System(WCS). 

 
) Purge Eliminates unreferenced elements from your drawing 

file. Regen Recalculates the display for the current window. 

On/Off Regen  Turns on and off the display recalculation. 
 
 

Copying settings 

A particularly powerful feature of the BtoCAD Explorer is its capability of copying many of the 
settings—layers, linetypes, text styles, coordinate systems, views, blocks, or dimension styles—from one 
drawing to another. If you have more than one drawing open, the BtoCAD Explorer makes it easy to reuse 
information. For example, when you copy layers from one drawing to another, the layer names as well as their 
linetypes, colors, and other settings are also copied, but not the entities on those layers. 

 
To copy layers from one open drawing to another open drawing 

1   Do one of the following: 
• 

On the Settings toolbar, click the Explore Layers tool  
• Type explayers and then press Enter. 

 
2   In the Elements pane, select the drawing from which you want to copy layers. 
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3   If necessary, click the plus (+) symbol to expand the Elements list for the drawing, and then click Layers. 
4   In the Layers Settings In Drawing list (right pane), select the layers you want to copy. 

5   Choose Edit > Copy, or click the Copy to  

6   In the Elements pane, select the drawing to which you want to copy the layers. 
7   If necessary, click the plus (+) symbol to expand the Elements list for the drawing, and then click Layers. 

8   Choose Edit > Paste, or click the Paste tool   . 
 

Deleting settings 

You can use the BtoCAD Explorer to delete many of the items that appear in the Elements list. You can 
delete a layer, linetype, text style, coordinate system, view, block, or dimension style. 
 
Because you may have already created entities on a particular layer or using a particular linetype or text style, 
deleting one of these elements requires that you make certain choices from options the program presents. For 
example, if you attempt to delete a layer, the program prompts you to specify whether you want to move any 
entities from that layer to another layer. Every drawing has at least one layer, the default layer, named “0.” 
You cannot delete or rename this layer. Your drawing can also contain an unlimited number of additional 
layers, each of which you assign a unique name. 
 
If you try to delete a linetype, the program prompts you to specify whether you want to convert all entities 
drawn using that linetype to a different linetype. If you attempt to delete a text style, the program prompts you 
to specify whether you want to convert all text entities created using that style to a different style. 
 
To delete a layer and relocate its entities to another layer 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Layers tool  

• Type explayers and then press Enter. 
 
2   From the Layer Name list, select the layer that you want to delete.If that layer is the current layer, layer 0 

automatically becomes the current layer. 
3   Choose Edit > Delete, or click the Delete tool ( ). 

4   From the dialog box, click Change. 
5   In the drop-down list, double-click the layer to which you want to relocate entities. 



Chapter 8 Working With the BtoCAD Explorer 

 123 

 
A  Click to delete the layer and all entities on the layer. 
B  Click to delete the layer after first relocating all of its entities to a selected layer. 
C  Click to cancel the layer deletion. 

Purging elements 

From within the BtoCAD Explorer, you can eliminate unused blocks, layers, line- types, text styles, or 
dimension styles from your drawing file. Purging unused ele- ments can significantly reduce the drawing file 
size. 
 
To purge an element 
1   Do one of the following: 

• Choose Tools > Explore Coordinate Systems. 

• 
On the Tools toolbar, click the BtoCAD Explorer tool  

• Type explayers and then press Enter. 
2   Select the element from which you want to purge unreferenced elements. 
3   From the Standard toolbar, select the Purge tool   . The main drawing window appears. 

4   In the command bar, do one of the following: 
•   Enter the name of the element to purge, and then press Enter. 

•   Press Enter to purge all unused elements of the selected type without confirming the removal of each 
element. 
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Organizing information on layers 

Layers in BtoCAD are like the transparent overlays you use in manual drafting. You use layers to organize 
different types of drawing information. In BtoCAD, each entity in a drawing exists on a layer. When you draw 
an entity, it is created on the current layer. 
 

You can control the visibility of layers in individual viewports. When you turn a layer off, entities drawn on 
that layer are no longer visible, and they do not print. Although a layer may be invisible, you can still select it 
as the current layer, in which case new entities are also invisible until you turn the layer back on. Entities on 
invisible layers can also affect the display and printing of entities on other layers. For example, entities on 
invisible layers can hide other entities when you use the Hide command to remove hidden lines. 
 
You can also freeze and thaw layers. Entities drawn on frozen layers do not display, do not print, and do not 
regenerate. When you freeze a layer, its entities do not affect the display or printing of other entities. For 
example, entities on frozen layers do not hide other entities when you use the Hide command to remove 
hidden lines. In addition, you cannot draw on a frozen layer until you thaw it, and you cannot make a frozen 
layer current. 
 
You cannot freeze the current layer. If you attempt to freeze the current layer, a dialog box appears prompting 
you to specify a different layer. You also cannot freeze or thaw a viewport layer unless you are working in a 
Layout tab. 
 

You can lock or unlock layers. The entities on a locked layer are still visible and will print, but you cannot edit 
them. Locking a layer prevents you from accidentally modifying entities. 
 

Each layer has its own color, linetype, and lineweight. For drawings that use named print styles, layers can 
also have their own print style. Entities you draw on a particular layer are displayed in the color, linetype, and 
lineweight associated with that layer unless you override these settings. You control all of the associated 
settings for layers using the Layers elements in the BtoCAD Explorer. 
 
To display layers in the BtoCAD Explorer 
Do one of the following: 
 

• Choose Tools > Explore Coordinate Systems. 

• 
On the Tools toolbar, click the BtoCAD Explorer tool  

• Type explayers and then press Enter. 
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A  Select Layers to display the Layers settings. 
B  Lists named layers in the current drawing. A check mark indicates the current layer. 
C  Displays the color assigned to each layer. 
D  Displays the linetype assigned to each layer. 
E  Indicates the visibility status of each layer. 
F  Indicates the locked or unlocked status of each layer. 

G  Indicates the frozen or thawed status of each layer for all viewports. 
H  Indicates the lineweight assigned to each layer. 
I   Indicates the print style assigned to each layer. 

J  Indicates the print status of each layer. 
K  Indicates the frozen or thawed status of the layer in the current viewport. 
L  Indicates the frozen or thawed status of the layer for new viewports on a Layout tab. 
M  Sorts the layers by that property when you click a column head. 

When Layers are displayed, three tools on the Layer toolbar provide the following functions: 
Layer On/Off toggles the selected layers on and off. 
Freeze/Thaw freezes or thaws the selected layers. 
Lock/Unlock locks or unlocks the selected layers. 

 
You can change any of these settings by clicking either the tool or its current condition. You can edit the 
color, linetype, lineweight, and other properties of a layer by clicking the corresponding name and selecting 
the values you want in the dialog box. You can also edit a layer’s properties by right-clicking it and 
choosing Properties. 
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A  Select to keep the dialog box on the screen when you switch back to the BtoCAD Explorer. 
B  Displays the name of the layer whose properties are being changed. 
C  Displays the current layer color. 
D  Choose the linetype assigned to the selected layer. 
E  Choose the lineweight assigned to the selected layer. 
F  Choose the print style assigned to the selected layer (only for drawings that use named print style tables). 
G  Click to display the Color dialog box to select a new color. 
H  Select or clear check boxes to control other properties of the selected layer. 

 

Creating and naming layers 

You can create an unlimited number of layers in every drawing and use those layers for organizing 
information. When you create a new layer, it is initially assigned the color white (or black, depending on your 
system settings) and the linetype CONTIN- UOUS. By default, a new layer is also visible. After you create 
and name a layer, you can change its color, linetype, visibility, and other properties 
 
NOTE  Layer names created or renamed in BtoCAD can have up to 31 characters and cannot include spaces. 
IntelliCAD will, however, display longer layer names and names containing spaces, such as layers created in 
AutoCAD 2000. 
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To create a new layer 

1   Do one of the following: 
• 

On the Settings toolbar, click the Explore Layers tool   

• Type explayers and then press Enter. 
 
2   Choose Edit > New > Layer. 

The program adds a new layer to the Layer Name list, with the default name NewLayer1. 

3   Type a name for the new layer over the highlighted default name, and then press Enter. 
4   To complete the command and return to your drawing, close the window. 
 
TIP You can also create a new layer by selecting the Layers element for a drawing and clicking the New Item 
tool ). 
 
To change a layer name in the current drawing 
1   Do one of the following: 
       

• 
On the Settings toolbar, click the Explore Layers tool   

• Type explayers and then press Enter. 
2   In the Layer Name list, select the layer you want to make current. 
3   Do one of the following: 

•   Choose Edit > Rename, type a new name, and then press Enter. 

•   Highlight the layer name you want to change, type a new name, and then press Enter. 

•   Right-click the layer name you want to change, and from the shortcut menu, select Rename, type 
a new name, and then press Enter. 

4   To complete the command and return to your drawing, close the window. 
 
NOTE  You cannot rename the 0 layer. 

Setting the current layer 

When you create new entities, they are drawn on the current layer. To draw new enti- ties on a different layer, 
you must first make that layer the current layer. 
 
To make a layer current 

1   Do one of the following: 
 
 
 
 

• 
On the Settings toolbar, click the Explore Layers tool   

• Type explayers and then press Enter. 
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2   In the Layer Name list, select the layer you want to make current. 
3   Do one of the following: 
•   Choose Edit > Current. 

•   In the Layer Name list, select the name you want to make current, and then click the Current tool ( ). 

•   Double-click the layer name in the Layer Name list. 

•   Right-click the layer name you want to change, and from the shortcut menu select Current. 

4   To complete the command and return to your drawing, close the window. 
 
To set the current layer to that of an existing entity 

1   Do one of the following: 
• 

On the Settings toolbar, click the Set Layer By Entity tool  
• Type setlayer and then press Enter. 

 
2   Select the entity to set the current layer. 
 

Controlling layer visibility 

A layer can be visible or invisible. Entities on invisible layers are not displayed and do not print. By 
controlling layer visibility, you can turn off unnecessary information, such as construction lines or notes. By 
changing layer visibility, you can put the samedrawing to multiple uses. 
 
For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer and the 
location of plumbing lines on another. By selectively turning layers on and off, you can print the electrical 
engineering drawings and the plumbing drawings from the same drawing file. For even more convenience, you 
can control the visibility of layers within individual viewports, so that layers that display in one viewport are 
invisible in other viewports in the same drawing. 
 

When you turn a layer off, entities drawn on that layer are no longer visible. When you turn the layer back 
on, the entities on that layer are redisplayed. 
 
To turn layers on or off 
1   Do one of the following: 
  
 
 
 
 
 
2   In the Layer Name list, select the layer you want to turn on or off. 
3   Do one of the following: 

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
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•   Choose View > On/Off. 

•   Right-click the layer you want to change, and from the shortcut menu, select Properties and turn the 
layer on or off. 

•   Click the setting in the On/Off column. The On/Off column shows the new setting. 

4 To complete the command and return to your drawing, close the window. You can also freeze layers to 
improve the performance of operations such as zooming and panning or producing hidden lines or shaded 
images. When a layer is frozen, entities drawn on that layer are no longer visible. To control the visibility 
of external reference layers and save any changes made to them in the current drawing, turn on Xref 
Layer Visibility. 

 
To turn on Xref Layer Visibility 
 
To turn layers on or off 
1   Do one of the following: 
  

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
2   In the Layer Name list, select the layer you want to turn on or off. 
3   Do one of the following: 

•   Choose View > On/Off. 

•   Right-click the layer you want to change, and from the shortcut menu, select Properties and turn the 
layer on or off. 

•   Click the setting in the On/Off column. The On/Off column shows the new setting. 

4   To complete the command and return to your drawing, close the window. 
 
You can also freeze layers to improve the performance of operations such as zooming and panning or 
producing hidden lines or shaded images. When a layer is frozen, entities drawn on that layer are no longer 
visible. 
 

To control the visibility of external reference layers and save any changes made to them in the current 
drawing, turn on Xref Layer Visibility. 
 
To turn on Xref Layer Visibility 
1   Do one of the following:      

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
 
2   Choose View > Xref Layer Visibility. 
 
TIP  You can also turn on this variable by typing visretain. 
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To freeze or thaw layers 
1   Do one of the following: 
  

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
 
2   In the Layer Name list, select the layers you want to freeze or thaw. 
3   Do one of the following: 

•   Right-click the layer you want to change, and from the shortcut menu, select Properties and freeze 
or thaw the layer. 

•   Click the setting in the All Viewports column. The All Viewports column shows the new setting. 

4   To complete the command and return to your drawing, close the window. 
 

Locking and unlocking layers 

Locking a layer makes it easy to refer to information contained on the layer, but pre- vents you from 
accidentally modifying its entities. When a layer is locked (but visible and thawed), its entities remain visible, 
but you cannot edit them. If you lock the cur- rent layer, you can still add new entities to it. You can also 
change the linetype and color associated with a locked layer. Unlocking a layer restores full editing 
capabilities. 
 
To lock or unlock layers 
1   Do one of the following: 
     
    

 
 
 

2   In the Layer Name list, select the layers you want to lock or unlock. 
3   Do one of the following: 

•   Right-click the layer name you want to change, and from the shortcut menu, select Properties and lock 
or unlock the layer. 

•   Click the setting in the Locked column. The Locked column shows the new setting. 

4   To complete the command and return to your drawing, close the window.

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
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Controlling layer printing 

Controlling layer printing is another way you can specify which entities print in your drawing. 
 

By controlling layer printing, you can turn off unnecessary information during print- ing. For example, if 
you are drawing a floor plan, you can draw the layout of light fix- tures on one layer and the location of 
plumbing lines on another. By selectively turning layers on and off when you print, you can print the 
electrical engineering drawings and the plumbing drawings from the same drawing file. By changing layer 
printing, you can put the same drawing to multiple uses. 
 

When you turn off printing for a layer, entities drawn on that layer are still visible, but they do not print. If 
you turn off a layer’s visibility, entities drawn on that layer do not display or print. Controlling layer printing 
can be especially helpful if you want layer visibility on, but do not want to print entities on that layer. 
 

Layer visibility must be turned on in order to print entities drawn on that layer. 
 
To turn layer printing on or off 
1   Do one of the following: 

 
 
 

On the Settings toolbar, click the Set Layer By Entity tool  
• Type setlayer and then press Enter. 

 
2   In the right pane, click the setting in the Print column for the layer you want to change. Choose Yes to 
print entities assigned to the layer. Choose No to omit enti- ties assigned to the layer during printing. 

You can also right-click the layer you want to change, and from the shortcut menu, select Properties and 
change the print setting for a layer. 
 

Setting the layer color 

Each layer in a drawing is assigned a color. BtoCAD uses the BYLAYER color as the default color setting 
for entity creation so that new entities are drawn in the color of the layer on which they are inserted (set in 
the Drawing Settings dialog box). 
 

Using the BtoCAD Explorer, you can set or change the color assigned to a layer. With the direct-editing 
feature, you can click on the color you want to change, and then select a new color from the dialog box that 
appears. Changing a layer’s color automatically changes the color of all entities on that layer with the 
BYLAYER color. 
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To change the layer color 
1   Do one of the following: 
          

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
 
2   In the right pane, click the color swatch for the layer you want to change. 
 
TIP Right-click the name of the layer you want to change, and from the shortcut menu, select Properties and 
change the layer color. 
 

 
3   In the Color dialog box, select a color on one of the following tabs: 
•   Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can also type the 
color number in the Index box. 

•   True Color — Click a basic color, click a color in the color palette, enter the Hue, Saturation, and 
Luminance (HSL) values, or enter the Red, Green, Blue (RGB) values. There are more than 16 million true 
colors from which you can choose. 

•   Color Books — Select a color book from the list, then click a color. You can select Show Only Color 
Book Colors Used in Drawing to limit the selection to only those color book colors that are used in the current 
drawing. If necessary, create or edit color books by clicking Color Book Editor. For more details, see“Using 
color books”. 
4   Click OK. 
 
NOTE You can also assign a specific color to an entity, which overrides the layer’s color setting. When you 
create a new entity, use the Settings > Colors > Select Color command to change the current color. For an 
existing entity, select the entity, right- click for the shortcut menu, and choose Properties. You can then 
change the entity’s color in the Entity Properties dialog box. 
 
For more details about using color in the many aspects of your drawing, see “Work- ing with colors”. 
 

Setting a layer’s linetype 

Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). Linetype determines the 
appearance of entities both on the screen and when printed. 
 

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that layer. BtoCAD uses the 
BYLAYER linetype as the default linetype setting for Entity Creation (in the Drawing Settings dialog box). 
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Using the BtoCAD Explorer, you can set or change the linetype assigned to a layer.With the direct-editing 
feature, you can click on the linetype you want to change, and then select a new linetype from the dialog box 
that appears. Changing the linetype assigned to a layer changes the linetype of all entities drawn on that layer 
with the BYLAYER linetype. 
 

NOTE  Only those linetypes already set in the drawing can be assigned to layers. For more information about 
setting additional linetypes, see see “Working withlinetypes” in this chapter. 
 
To change the linetype assigned to one or more layers 
1   Do one of the following: 
            

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
 
2   In the right pane, click the linetype for the layer you want to change. 
3   In the Linetype dialog box, select a new linetype for the layer, or click Browse to select your linetype 
file.You can also right-click the layer you want to change, and from the shortcut menu, select Properties and 
change the linetype assigned to a layer. 
 
NOTE  You can also assign a specific linetype to an entity, which overrides the layer’s linetype setting. When 
you create a new entity, use the Settings > Explore Linetypes command to change the current linetype through 
the BtoCAD Explorer. For an existing entity, select the entity, right-click for the shortcut menu, and choose 
Properties. You can then modify the entity’s linetype in the Entity Properties dialog box. 
 

Setting a layer’s lineweight 

Each layer uses a default lineweight. Lineweights determine the thickness of entities both on the screen and 
when printed. 
 

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or.01 inches. If you want a 
different lineweight assigned to a layer, you can easily change it using BtoCAD Explorer. For example, you 
may want different line- weights on each layer of your drawing to show separate elements, such as walls, 
dimensions, structural steel, and electrical plans. Changing the lineweight assigned to a layer changes the 
lineweight of all entities drawn on that layer with the BYLAYER lineweight. 
 
When you create new entities, it’s a good idea to assign the BYLAYER lineweight toany entities that you 
draw on that layer, unless you want to override the layer line- weight. BtoCAD uses the BYLAYER 
lineweight as the default lineweight setting when you create entities (in the Drawing Settings dialog box). 
 

 
TIP  To change the DEFAULT lineweight, choose Settings > Drawing Settings, click the Display tab, select 
Lineweights in Change Settings For, and then select a new default. 
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To change the lineweight assigned to one or more layers 

1   Do one of the following: 
          

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
2   In the right pane, click the lineweight for the layer you want to change. 
3   In the Lineweight list, click the arrow to scroll the lineweights, and then select a new lineweight for the 
layer. 

You can also right-click the layer you want to change, and from the shortcut menu, select Properties and 
change the lineweight assigned to a layer. 
 
NOTE  You can also assign a specific lineweight to an entity, which overrides the layer’s lineweight setting. 
When you create a new entity, use the Settings > Drawing Settings > Entity Creation tab to change the 
current lineweight. For an existing entity, select the entity, right-click for the shortcut menu, and choose 
Properties. You can then modify the entity’s lineweight in the Entity Properties dialog box. 
 

Setting a layer’s print style 

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style 
tables contain print styles that you set up to control what entities look like when they print, without actually 
changing the entities in the drawing. 
 

If your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These 
types of print style tables automatically determine printing requirements by the color assigned to a layer or 
an entity. For details about converting a drawing that uses color-dependent print style table to use named 
print style tables, see “Changing a drawing’s print style table type”. 
 

In drawings that use named print style tables, the default print style is Normal for all new layers. If desired, 
you can assign a print style using BtoCAD Explorer. Chang- ing the print style assigned to a layer changes 
the print style of all entities drawn on that layer with the BYLAYER print style. 
 
When you create new entities, it’s a good idea to assign the BYLAYER print style to any entities that you 
draw on that layer, unless you want to override the layer print style. BtoCAD uses the BYLAYER print style 
as the default print style setting when you create entities (in the Drawing Settings dialog box). 
 
To change the print style assigned to one or more layers (only in a drawing that uses named print style 
tables) 

1   Do one of the following: 
       

• 
On the Settings toolbar, click the Set Layer By Entity tool  

• Type setlayer and then press Enter. 
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2   In the right pane, click the print style for the layer you want to change. 
3   If necessary, select a different print style table in the Active Print Style Table list. 

4   In Print Styles, select a print style. 
5   Click OK. 

You can also right-click the layer you want to change, and from the shortcut menu, select Properties and 
change the print style assigned to a layer. 
 
NOTE  For drawings that use named print style tables, you can also assign a specific print style to an entity, 
which overrides the layer’s print style setting. When you cre- ate a new entity, use the Settings > Drawing 
Settings > Entity Creation tab to change the current print style. For an existing entity, select the entity, 
right-click for the shortcut menu, and choose Properties. You can then modify the entity’s print style in 
the Entity Properties dialog box. 
 

Working with linetypes 

BtoCAD provides simple and complex linetypes: 
 

•   A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces. 
•   A complex linetype contains embedded shape and text entities along with dots, dashes, and 
spaces. 
You can use different linetypes to represent specific kinds of information. For exam- ple, if you are 
drawing a site plan, you can draw roads using a continuous linetype, a fence using a using a linetype 
of dashes with square posts, or a gas line using a com- plex linetype showing the text “GAS”. 

 
By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and BYBLOCK. You 
cannot rename or delete these linetypes. Your drawing may also contain an unlimited number of additional 
linetypes. You can load more line- types into the program from a linetype library file or create and save 
linetypes you define. 
 
To display the BtoCAD Explorer Linetypes element 
Do one of the following: 
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• 

On the Settings toolbar, click the Explore Linetypes tool  
• Type expltypes and then press Enter. 

 
•   Choose Tools > BtoCAD Explorer, and then click the Linetypes element. 

 
 
A  Select Linetypes to display the Linetypes settings. 
B  Lists names of linetypes loaded in the current drawing. A check mark indicates the current linetype. 
C  Describes linetypes loaded in the current drawing. 
D  Shows how linetypes will appear in the drawing. 
E  Sorts the linetypes by that property when you click a column head 

Setting the current linetype 

You normally draw an entity using the linetype assigned to the current layer, indicated as BYLAYER. You 
can also assign linetypes on a per-entity basis, which over- rides the layer’s linetype setting. A third option is 
to assign the BYBLOCK linetype, whereby you draw new entities using the default linetype until you group 
them into a block. The entities inherit the current linetype setting when you insert the block into the drawing. 
 
To make the linetype current 

1   Do one of the following: 
• 

On the Settings toolbar, click the Explore Linetypes tool  
• Type expltypes and then press Enter. 

2   In the Linetype Name list, select the linetype you want to make current. 
3   Do one of the following: 

• Choose Edit > Current.  
• Select it in the Linetype Name list and click the Current tool ( ). 
• Double-click the linetype name.  

 



Chapter 8 Working With the BtoCAD Explorer 

 137 

4   To complete the command and return to your drawing, close the window. 
 

Loading additional linetypes 

Before you can select a new linetype to use in a drawing, you must either create the linetype definition or load 
a predefined linetype from a linetype library file (*.lin). IntelliCAD includes a linetype library file, icad.lin, 
which contains more than 100 predefined linetypes. 
 
To load a new linetype from a linetype library 
1  Do one of the following: 
 
 
 
 
 
2   Using one of the following methods, open the New Linetype dialog box: 
•   Choose Edit > New > Linetype. 

•   Click the New Item tool ( ). 

•   With the cursor in the right pane of the window, right-click to display the shortcut menu, and then 
choose New > Linetype. 

3   Click Choose From File. 
4   Click Browse. 

5   Select the linetype library file, and then click Open. 
6   Select the linetype you want to load. 

7   Click OK, and then close the window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• 
On the Settings toolbar, click the Explore Linetypes tool  

• Type expltypes and then press Enter. 
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Creating and naming linetypes 
In addition to loading predefined linetypes from a linetype library file, you can create new linetypes. You can 
save new linetypes you create to a linetype library file for use in other drawings. 
 
NOTE  Linetype names created or renamed in BtoCAD can have up to 31 characters and cannot include 
spaces. BtoCAD will, however, display longer linetype names and names containing spaces, such as linetypes 
created in AutoCAD 2000. 
 
To create a new simple linetype 

1   Do one of the following: 
• 

On the Settings toolbar, click the Explore Linetypes tool  
• Type expltypes and then press Enter. 

 
2   Using one of the following methods, open the New Linetype dialog box: 
•   Choose Edit > New > Linetype. 

•   Click the New Item tool ( ). 

•   With your cursor in the right pane of the window, right-click to display the shortcut menu, and 
choose New > Linetype. 

3   In the Linetype Description field, type the linetype description. You can type anything in this field that 
will help you remember the purpose or appearance of this linetype. For example, it is helpful to type text or 
symbols such as __..__.. that approximate the appearance of the linetype. 
4   In the Linetype Definition field, type the linetype definition. The definition consists of positive and 
negative numbers separated by commas. A positive number draws a solid line segment for the specified 
number of drawing units; a negative number creates a gap for the specified number of units; a zero creates a 
dot. 
5   Click OK.The program adds the new linetype to the linetypes list with the default name, NewLinetype1. 
6   To enter a name for the new linetype, type over the highlighted default text, and press Enter.Do not use 
spaces between words in the new linetype name. 

7   To complete the command and return to your drawing, close the window. 

 
A  Click to select a predefined linetype from a linetype library file. 
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B  Type any description in this box that helps you remember the purpose or appearance of the linetype. 

C  Type the definition of the linetype, consisting of positive and negative numbers separated by commas. 
 

To create a new complex linetype 

A complex linetype can denote utilities, boundaries, contours, and so on. As with simple linetypes, complex 
lines are dynamically drawn as the user specifies vertices. Shapes and text entities embedded in lines are 
always displayed completely; they are never trimmed. 
 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Linetypes tool  

• Type expltypes and then press Enter. 
 
2   Using one of the following methods, open the New Linetype dialog box: 
•   Choose Edit > New > Linetype. 

•   Click the New Item tool ( ). 

•   With your cursor in the right pane of the window, right-click to display the shortcut menu, and choose New > 
Linetype. 

 

3   In the Linetype Description field, type the linetype description.You can type anything in this field that 
will help you remember the purpose or appearance of this linetype. For complex linetypes, it is helpful to type 
a text description of the linetype. 
 
4 In the Linetype Definition field, type the linetype definition.As for the simple linetypes, the syntax for a 

complex linetype is a comma delimi- nated list of pattern descriptors. For more details, see “Syntax for a 
complex line- type definition”. 

 
5   Click OK. 
The program adds the new linetype to the linetypes list with the default name, NewLinetype1. 

6   To enter a name for the new linetype, type over the highlighted default text, and press Enter.Do not use 
spaces between words in the new linetype name. 
7   To complete the command and return to your drawing, close the window. 
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Syntax for a complex linetype definition 

Complex linetypes can include shape and text entities as pattern descriptors, as well as the dash and dot 
descriptors of simple linetypes. 
 
The shape descriptor syntax 

You can add a shape entity to a complex linetype using the following syntax: 
 
[shape_name, shape_filename] or [shape_name, shape_filename, transform] The definitions of the 

fields in the syntax are as follows. 

shape_name The name of the shape to add to the linetype. The shape name must exist in the specified shape 
file (shape_filename). 
 

shape_filename The name of a compiled shape definition file (extension *.shx). If no path is defined for the 
shape file name, the library path is searched for the file. 
 

transform The transform argument is optional and can be any series of the following(each preceded by a 
comma): R=value Relative rotation  

A=value Absolute rotation  
S=value Scale 
X=value   X offset 

Y=value    Y offset 
 
In this syntax, value represents a signed decimal number. The rotation is expressed in degrees while the other 
options are in linetype scaled drawing units. 
 

rotation R=value or A=value. 

R= determines a relative or tangential rotation with respect to the line’s elaboration. A= determines an absolute 

rotation of the shape with respect to the origin. All shapes have the same rotation regardless of their relative 

position to the line. The value can be appended with a d for degrees (default), r for radians, or g for grads. If 

rotation is omitted, 0 relative rotation is used. 
 
scale S=value. 
 
Determines a factor by which the shape's internal scale is multiplied. If the shape's internal scale is 0, the 
scale value is used as the scale. 
 

 
X offset X=value. 
 
Determines a shift of the shape along the X axis of the linetype computed from the end of the linetype 
definition vertex. If X offset is omitted or is 0, the shape is elabo- rated with no offset. Include this field if you 
want a continuous line with shapes. This value is not scaled by the scale factor defined by S. 
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Y offset Y=value. 
 
Determines a shift of the shape along the Y axis of the linetype computed from the end of the linetype 
definition vertex. If Y offset is omitted or 0, the shape is elabo- rated with no offset. This value is not 
scaled by the scale factor defined by S. 
 
The text descriptor syntax 

You can add a text entity to a complex linetype using the following syntax:["string", style_name] or ["string", 
style_name, transform] The definitions of the fields in the syntax are as follows. 
 
string The text to be used in the complex linetype. You cannot use the ` or the " char- acters in the text string. 
To use these characters, enter a control code (%%) with the ASCII value for the character instead. 
 

style_name The name of the text style to be elaborated. The specified text style must be included. If it is 
omitted, use the currently defined style. 
 

transform The transform argument is optional and can be any series of the following(each preceded by a 
comma): R=value  Relaive rotation  

A=value  Absolute rotation  
S=value  Scale 
X=value  X offset 
Y=value Y offset 

 
In this syntax, value represents a signed decimal number. The rotation is expressed in degrees while the other 
options are in linetype scaled drawing units. 

rotation R=value or A=value. 

R= determines a relative or tangential rotation with respect to the line’s elaboration. A= determines an 

absolute rotation of the text with respect to the origin. All text has the same rotation regardless of its relative 

position to the line. The value can be appended with a d for degrees (default), r for radians, or g for grads. If 

rotation is omitted, 0 relative rotation is used.Rotation is centered between the baseline and the nominal cap 

heights box. 
 
scale S=value. 
 
Determines a factor by which the style's height is multiplied. If the style's height is 0, the scale value is used as 
the scale. 
 

Because the final height of the text is defined by both the scale value and the height assigned to the text style, 
you will achieve more predictable results by setting the text style height to 0. It is recommended that you 
create separate text styles for text in complex linetypes to avoid conflicts with other text in your drawing. 
X offset X=value. 
 
Determines a shift of the text along the X axis of the linetype computed from the end of the linetype definition 
vertex. If X offset is omitted or is 0, the text is elaborated by using the lower left corner of the text as the offset. 
Include this field if you want a continuous line with text. This value is not scaled by the scale factor that is 
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defined by S. 
 

Y offset Y=value. 
 
Determines a shift of the text along the Y axis of the linetype computed from the end of the linetype 
definition vertex. If Y offset is omitted or is 0, the text is elaborated by using the lower left corner of the text 
as the offset. This value is not scaled by the scale factor that is defined by S. 
 

Editing linetypes 

To change a linetype name 

1   Do one of the following: 
• 

On the Settings toolbar, click the Explore Linetypes tool  
• Type expltypes and then press Enter. 

 
2   Do one of the following: 
•   Select the linetype, and then choose Edit > Rename. 

•   Click the linetype name you want to change, and then type the new name. 

•   Right-click the linetype name you want to change, and from the shortcut menu, select Rename. 

 

3   To complete the command and return to your drawing, close the window. 
 
To change a linetype definition 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Linetypes tool  

• Type expltypes and then press Enter. 
 
2   Right-click on the linetype name for which you want to change the definition. 
3   From the shortcut menu, select Properties. 

4   In the Linetype Definition field, define the linetype using positive and negative numbers and zeros.A 
positive number draws a solid line segment for the specified number of drawing units. A negative number 
creates a gap for the specified number of drawing units.A zero creates a dot. 

5   To complete the command and return to your drawing, close the Linetypes dialog box and the BtoCAD 
Explorer window. 
 
NOTE  You cannot rename the CONTINUOUS, BYBLOCK, or BYLAYER linetypes 
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Working with text fonts and styles 

When you add text to a drawing, it is created using the current text style. The text style determines the 
font, size, angle, orientation, and other text characteristics. 

 

Every drawing has at least one text style, named Standard, which initially uses the txt font. You cannot delete 
the Standard style, but you can rename it or modify it. For example, you can change the font or the oblique 
angle applied to the font. You also can use an unlimited number of additional text styles in your drawing. 

 
From the BtoCAD Explorer, you can directly edit any setting associated with a text style by using the 
single-click editing method to change the setting. 
 
To display the BtoCAD Explorer Text Styles element 

Do one of the following: 
•  Choose Tools > Explorer Coordinate Systems, and then click the Text Styles element. 
• 

On the Settings toolbar, click the Explore Text Styles tool   
• Type expstyles and then press Enter. 
 

A  Select Text Styles to display the text style settings. 
B  Lists names of text styles defined in the current drawing. A check mark indicates the current style. 
C  Displays the height assigned to the text style. 
D  Displays the width factor assigned to the text style. 
E  Displays the oblique angle assigned to the text style. 
F  Displays the font on which the style is based. 
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G  Displays the font style, such as bold or italic. 
H  Displays the language on which the text style is based. 
I  Displays whether Asian language big font files are used (for .shx file fonts only). 
J  Indicates whether text will appear backward. 
K  Indicates whether text will appear upside down. 
L  Indicates whether text will appear vertically. 
M  Click any column head to sort the styles by that property. 

 

Creating and naming text styles 

Fonts are character sets that consist of letters, numbers, punctuation marks, and sym- bols. Each font is stored 
in its own font file. Text styles apply additional formatting to fonts. You can create multiple text styles based 
on the same font, changing the vari- ous characteristics to alter the appearance of the font. To create a new 
text style, you assign formatting characteristics to a font. 
BtoCAD uses *.shx font files and provides a selection of fonts. These fonts are located in the 
BtoCAD/Fonts directory. You can also use any font designed to work with AutoCAD. Many fonts are 
available from third-party vendors. 
 

 
NOTE  Text style names created or renamed in BtoCAD can have up to 31 characters and cannot include 
spaces. BtoCAD will, however, display longer text style names and names containing spaces, such as text 
styles created in AutoCAD. 
 
To create a new text style 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Text Styles tool  

• Type expfonts and then press Enter. 
 
2   Choose Edit > New > Text Style. 
3   Select the font on which you want to base the new style, and then click Open. The program adds a 

new style to the text styles list with the default name,NewStyle1. 

4   Type the name for the new style by typing over the highlighted default text, and then press Enter. 

5   To complete the command, close the window. 
 
TIP You can also create a new text style by selecting the Text Styles element and clicking the New Item tool 
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To change a text style name in the current drawing 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Text Styles tool  

• Type expfonts and then press Enter. 
 
2   Do one of the following: 
•   Select the text style, choose Edit > Rename, type a new name, and then pressEnter. 

•   Click the text style name you want to change, type a new name, and then pressEnter. 

•   Right-click the text style name you want to change, and from the shortcut menu, select Rename, type a 
new name, and then press Enter. 

3   To complete the command and return to your drawing, close the window. 
 

Modifying text styles 

A new text style is initially assigned default values for height, width factor, oblique angle, and other 
characteristics. You can change these values for both new and exist- ing text styles. You can also change the 
font assigned to the text style. If you change the font or orientation properties of a text style assigned to text 
previously inserted in the drawing, all text using that style is regenerated to reflect the changes. Oblique angle 
and height, if specified, are given by the style definition when text is created,but are not updated for existing 
text when the style is changed. 
 
A fixed text height value of 0 allows you to specify the text height at the time you insert text into the drawing. 
Any other value sets height of the text to that value; the program does not prompt for the text height when you 
insert text into the drawing. The width factor determines the horizontal scaling of text. A value less than 1 
com- presses the text (for example, 0.75 compresses the text 25 percent); a value greater than 1 expands the 
text (for example, 1.50 expands the text 50 percent). The oblique angle determines the forward or backward 
slant of text as an angle offset from 90 degrees. Negative values slant text to the left; positive values slant text 
to the right. 
 
To modify a text style 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Text Styles tool  

• Type expfonts and then press Enter. 
 
2   Select the text characteristic of a style that you want to modify.The text characteristic either toggles its 
value or a dialog box appears, allowing you to make the modifications you want. 
 
3   To complete the command, close the BtoCAD Explorer window. 
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A  Select to keep the dialog box on the screenwhen you switch back to the IntelliCAD Explorer or another element. 
B  Displays the name of the text style whose properties are being changed. 
C  Type the fixed text height. 
D  Type the width factor. 
E  Type the oblique angle. 
F  Select to create text that displays backward. 
G  Select to create text that displays upside down. 
H  Select to create text that displays vertically. 
I   Displays a text preview of the text font. 
J  Select the Asian language big font (for .shx file fonts only) 
K  Select the text style language. 
L  Select the font style. 
M  Select the font name. 

 Setting the current text style 

When you insert text in a drawing, the text is created using the current text style. You can also select a 
different text style when you create text. 
 
To make the text style current 
1   Do one of the following: 

• 
On the Settings toolbar, click the Explore Text Styles tool  

• Type expfonts and then press Enter. 
 
2   In the Text Style Name list, click the style you want to make current. 
3   Use one of the following methods to make the style the current style: 

• Choose Edit > Current.  
• Click the Current tool ( ).
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•   With the cursor in the right pane of the window, right-click to display the shortcut menu, and choose 
Current. 
 

4   To complete the command and return to your drawing, close the BtoCAD Explorer window. 
 
 
TIP You can also make a text style current by selecting it in the Text Style Name list and clicking the Current 
tool ) or by double-clicking the text style name in theText Style Name list. 
 

Working with coordinate systems 

When you create entities in a drawing, they are located in relation to the drawing’s underlying Cartesian 
coordinate system. Every drawing has a fixed coordinate system called the World Coordinate System (WCS). 
You cannot delete or modify the WCS. 
 

Your drawing may contain additional coordinate systems, however, each with its own 0,0,0 origin and 
orientation. You can create as many user coordinate systems as you want, and then save and recall them as you 
need them. You can edit the origin of a coordinate system from within the BtoCAD Explorer by single-clicking 
the origin coordinates and then typing new coordinates. 
 

For example, you can create a separate user coordinate system (UCS) for each side of a building. Then, by 
switching to the UCS for the east side of the building, you can draw the windows on that side by specifying 
only their x- and y-coordinates. 
 

You can create and then switch between various user coordinate systems by selecting Coordinate Systems in 
the BtoCAD Explorer. 
 
To display the Coordinate Systems element 
Do one of the following: 
•   Choose Tools > Explore Coordinate Systems. 

 
 

A  Select Coordinate Systems to display the Coordinate  Systems settings. 
B  Lists names of coordinate systems defined in the current drawing. A check mark indicates the current coordinate system. 
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C  Displays the origin of the coordinate system in relation to the WCS. 
D  Displays the x-axis direction of the coordinate system in relation to the WCS. 
E  Displays the y-axis direction of the coordinate system in relation to the WCS. 
F  Click any column head to sort the coordinate systems by that property. 

Defining and naming user coordinate systems 

A drawing can contain as many coordinate systems as you want and can be named appropriate names so 
you can remember how they are used in your drawing for recalling them later. 
 
NOTE  Coordinate system names created or renamed in BtoCAD can have up to 31 characters and cannot 
include spaces. BtoCAD will, however, display longer coordinate system names and names containing spaces, 
such as coordinate systems created in AutoCAD 2000. 
 
To define new user coordinate systems in the BtoCAD Explorer 
1   Do one of the following: 

• Choose Tools > Explore Coordinate Systems.  
• Type expucs and then press Enter.  

 
2   Do one of the following: 

•   Choose Edit > New > UCS. 

•   Click the New Item tool ( ). 

•   With your cursor in the right pane of the window, right-click to display the shortcut menu, and 
choose New > UCS. 

3   Select a method from the prompt box or command bar by which to define the UCS in the drawing 
window. 

4   Type the name for the new user coordinate system by typing over the highlighted default text, and then 
press Enter. 

5   To complete the command, close the window. 
 
To change a user coordinate system name in the current drawing 
1   Do one of the following: 

• Choose Tools > Explore Coordinate Systems.  
• Type expucs and then press Enter.  

 
2   Do one of the following: 

•   Select the user coordinate system, and then choose Edit > Rename, type a new name, and then press 
Enter. 

•   Click the user coordinate system name you want to change, type a new name, and then press Enter. 

•   Right-click the user coordinate system name you want to change, and from the shortcut menu, select 
Rename, type a new name, and then press Enter. 
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3   Type the new user coordinate system name, and then press Enter. 
4   To complete the command and return to your drawing, close the window. 

Setting the current user coordinate system 

When you draw new entities, they are created in relation to the current coordinate system. You can set the 
current UCS from the BtoCAD Explorer. 
 
To set the current UCS from the BtoCAD Explorer 

Do one of the following: 
• Double-click the UCS name in the UCS Name list.  
• Select the UCS in the UCS Name list, and then choose Edit > Current.  
• Select the UCS in the UCS Name list, and then click the Current tool . 

Using named views 

As you work on a drawing, you may find that you frequently switch among different portions of it. For 
example, if you are drawing the floor plan of a house, you may zoom in to particular rooms of the house and 
then zoom out to display the entire house. Although you can repeat the Pan and Zoom commands to do this, it 
is much easier to save various views of the drawing as named views. You can then quickly switch among 
these views. You can save and later restore named views using either the View command or the Views 
element in the BtoCAD Explorer. 
 
To display Views in the BtoCAD Explorer 
Do one of the following: 
•Type expviews and then press Enter. 
•   Choose Tools > Explorer Coordinate Systems, and then click the Views element. 
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A  To display the Views settings, select Views. 
B  Lists names of views defined in the current drawing. A check mark indicates the current view. 
C  Displays the height of the view in drawing units. 
D  Displays the width of the view in drawing units. 
E  Displays the direction of the view, expressed as a three- dimensional coordinate in the WCS. 
F  Click any column head to sort the views by that property. 

Saving and naming views 

You can save the view displayed in the current window as a named view. After you save a named view, you 
can restore that view in the current window at any time. 
 

 
NOTE  View names created or renamed in BtoCAD can have up to 31 characters and cannot include spaces. 
BtoCAD will, however, display longer view names and names containing spaces, such as views created in 
AutoCAD 2000. 
 
To save the current view as a named view 
1   Do one of the following: 

• Choose View > Save/Restore View. 
• Type view and then press Enter. 

2   In the prompt box, choose Save. 
3   Type a name for the view, and then press Enter. 

4   To complete the command and return to your drawing, close the window. 
5   Specify the opposite corner of the view window. 
6   Rename the new view, and then press Enter.Do not use spaces between words in the new view name. 

7   To complete the command and return to your drawing, close the window. 
 
To change a saved view name in the current drawing 
 
1  Type expviews and then press Enter. 
 
2   Do one of the following: 
•   Select the view, choose Edit > Rename, type a new name, and then press Enter. 

•   Click the view name you want to change, type a new name, and then press Enter. 

•   Right-click the view name you want to change, and from the shortcut menu, select Rename, type a 
new name, and then press Enter. 

3   Type the new view name, and then press Enter. 
4   To complete the command and return to your drawing, close the window. 
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Restoring named views 

After you save one or more named views, you can restore any of those views in the current window using 
either the View command or the BtoCAD Explorer. 
 
To restore a named view using the View command 
1   Do one of the following: 

• Choose View > Save/Restore View. 
• Type view and then press Enter. 

 
2   In the prompt box, choose Restore. 
3   Type the name of the view you want to restore, and then press Enter. 
 
To restore a named view from the BtoCAD Explorer 
Do one of the following: 

•   Select the view name in the list of View settings, and then choose Edit > Current. 
•   Select the view name in the list of View settings, and then click the Current tool 

•   Double-click the view name in the View list. 

Changing named view properties 

Once you create a named view you can modify its properties, such as the target direction and twist angle. This 
gives you access to many of the view settings after a view has been defined. 
 
To change the view options 
1   Type expviews and then press Enter. 
2   Select the view whose properties you want to change. 
3   Choose Edit > Properties. 
You can also right-click the view you want to change, and from the shortcut menu, select Properties. 

4   Change the values of the settings on any of the tabs and close the dialog box. 
5   To complete the command and return to your drawing, close the window. 

 

Working with blocks and external references 

Blocks represent a special type of entity that, once saved, can be inserted and manip- ulated in the drawing 
as a single entity. A block can consist of visible entities such as lines, arcs, and circles as well as visible or 
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invisible data called attributes. You can use attributes to track things such as part numbers and prices and to 
export attribute information to an external database. You can also track the number of parts by count- ing 
the number of times a block has been inserted into the drawing. Blocks are stored as part of the drawing file. 
 
External references have similar uses to blocks. Using external references, you can attach entire drawings to 
your current drawing. Unlike a block, however, an external reference does not become part of the current 
drawing. 
 

You can save blocks in the BtoCAD Explorer. You can also use the BtoCAD Explorer to manage and 
insert copies of blocks. The BtoCAD Explorer lists the names of all blocks contained in the current 
drawing, along with other information about each block or external reference. 
 
You can also rename a block, modify its insertion point, and change the path of an externally referenced 
drawing by single-clicking on the property and making your edits within the BtoCAD Explorer. 
 
To display blocks in the BtoCAD Explorer 
Do one of the following: 
 
•  Choose Tools > Explorer Coordinate Systems, and then click the Blocks element. 

• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

 
The Blocks element in the BtoCAD Explorer defaults with images on. The Images view shows you a small 
image of each block or external reference. 
 
 
 

 
 
The Images view shows an image of each block in the selected drawing. Click an image to select it. 
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When blocks are displayed, additional tools on the Block toolbar provide the func- tions described in the 
following table: 
 
Additional tools on the Block toolbar 

Tool                                   Function 
 

) Images Displays a small image of each block. 
 

) Details Displays information about each block. 
 

) Insert Inserts a block. 
 
Additional tools on the Block toolbar 

 
Tool                                  Function 

 
) Insert External File Blocks Inserts a drawing available from disk as a block. 

 
) Save Block Saves selected block as independent.dwg file. 

 
) Attach Drawing Attaches drawing as an external reference. 

 
To see more information about each block, click the Details tool (    ). In the Details view, you can edit the 
path and the insertion point by clicking the setting and typing your changes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A  To display the Blocks settings, select Blocks.  B  Lists names of blocks and external references defined in the current drawing. 
C  Displays the number of occurrences of the block in the current drawing. D  Displays the insertion point of the block in the current 
drawing.      E Displays the name and path for externally referenced drawings. F  Click any column head to sort the blocks by 
that property. 

Creating and naming blocks 

You can combine any number of entities into a single block. After you create a block, you can insert copies of it 
into a drawing. Each block insertion is treated as a single entity; for example, you can rotate or scale each block 
when you insert it. The program adds the name of the new block you insert to the Block Name list in the 
BtoCAD Explorer. 
 

To create a block 
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1   Do one of the following: 
• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

 
2   Do one of the following: 

• Choose Edit > New > Block. 

• On the BtoCAD Explorer toolbar, click the New Item tool  
 
3   Enter a name for the new block. 
4   Specify the insertion point for the block. 
5   Select the entities to be combined into the block, and then press Enter.The program adds a new block to 
the blocks list, with the name you entered for it. 
6   To complete the command and return to your drawing, close the window. 
 
To change a block name in the current drawing 
1   Do one of the following: 

• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

 
2   Do one of the following: 
•   Select the block, choose Edit > Rename, type a new name, and then press Enter. 

•   Click the block name you want to change, type a new name, and then pres Enter. 

•   Right-click the block name you want to change, and from the shortcut menu, select Rename, type a 
new name, and then press Enter. 

3 To complete the command and return to your drawing, close the window. 

Inserting a block 

You can insert into a drawing any block listed in the Block Name list in the BtoCAD Explorer. This includes 
blocks contained within any open drawing. 
 
To insert a block 

1   Do one of the following: 
• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

2   If you want to insert a block from another open drawing, select the drawing in the Elements pane. (If the 
block is contained within the same drawing, you can skip this step.) 

3   In either the Details or Images view, select the block to be inserted. 
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4   On the BtoCAD Explorer toolbar, click the Insert tool ( ). 

5   In the drawing, specify the insertion point. 
6   Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select Done. 

7   To complete the command and return to your drawing, close the window. 
 
TIP  You can also insert a block from the Insert menu “Working with blocks, attributes, and external 
references.” 

Inserting a drawing as a block 

You can insert as a block another drawing into the current drawing. After you do this, the block name is 
added to the Block Name list in the BtoCAD Explorer. Changes made later to the inserted drawing will not 
be reflected in this drawing. 
 
To insert a drawing as a block 

1   Do one of the following: 
• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

2   On the BtoCAD Explorer toolbar, click the Insert External File Blocks tool 
3   In the Insert Block dialog box, select the drawing you want to insert, and then click Open. 
4   In the drawing, specify the insertion point. 
5   Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select Done. 

6   To complete the command and return to your drawing, close the window. 

Attaching a drawing as an external reference 

You can attach another drawing to the current drawing as an external reference and insert a copy of the 
drawing into the current drawing. The name of the external refer- ence drawing is added to the Block Name 
list. Changes made later to the referenced drawing will appear in this drawing when you reload the external 
reference. 
 
To attach an external reference 

1   Do one of the following: 
• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

2   On the BtoCAD Explorer toolbar, click the Attach Drawing tool  
3   In the Select File To Attach dialog box, select the drawing you want to attach, and then click Open. 

4   In the drawing, specify the insertion point. 
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5   Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select Done. 

6   To complete the command and return to your drawing, close the window. 
 
To edit the path of an external reference 

1   Do one of the following: 
• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

 
2   Click the path you want to change. 
3   From the Insert Block dialog box, select the new drawing you want as the external reference. 

4   Click Open. 
5   To complete the command and return to your drawing, close the window. 
 
Saving a block as a separate drawing 

You can save a block as a separate drawing, and then you can open and modify that drawing as you would 
any other drawing. 
 
To save a block as a separate drawing file 

1   Do one of the following: 
• On the Settings toolbar, click the Explore Blocks tool  
• Type expblocks and then press Enter. 

2   In either the Details or Images view, select the block you want to save. 
3   On the BtoCAD Explorer toolbar, click the Save Block To Disk tool ( ). 
4   In the Save Block dialog box, select the folder in which you want to save the block. 

5   In the File Name field, type a name for the new drawing file (or accept the default, in which case the 
new drawing name is the same as the name of the block), and then click Save. 

Working with dimension styles 

From the BtoCAD Explorer, you can use the Dimension Styles element to cut, copy, and paste dimension 
styles from one drawing to another. 
 
TIP You can select the dimension style and use the Windows shortcut keys (Ctrl+A to select all, Ctrl+X to cut, 
Ctrl+C to copy, Ctrl+V to paste) to accomplish the same results. You can use these shortcut keys with all 
other BtoCAD Explorer elements as well. 
 

 
A dimension style contains the settings that control the appearance of a dimension. Although you cannot 
control these settings from within the BtoCAD Explorer, you can use the Dimension Settings dialog box to 
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control settings related to the appear- ance of arrows, lines, text, units, and other formatting characteristics. 
 
To display the BtoCAD Explorer Dimension Styles element 

Do one of the following: 
•   Choose Tools > Explorer Coordinate Systems, and then click the Dimension Styles element. 

•   Type setdim and then press Enter 

 
 
 
 

 
 
 
 
 
 
 
A  To display the Dimension Styles settings, select Dimension Styles. 
B  Lists the names of dimension styles defined in the current drawing. 
C  Click the Dimension Style Name column head to sort by name. 

Creating and naming dimension styles 

By using the Dimension Styles element in combination with the Dimension Settings dialog box, you can 
create new dimension styles, modify them, and copy them into a different drawing. 
 

To create a dimension style 
1   Do one of the following: 

• 
On the Settings toolbar, click the Dimension Settings tool (  

• Type setdim and then press Enter. 
2   In the Dimension Settings dialog box, click New. 
3   Type the name of the new dimension style. 
4   Click Create. 

5   In the Dimension Settings dialog box, click one of the other tabs, and then change the dimension settings 
as necessary.Repeat this step for each tab, as needed. 

6   To end the command, click OK. 
 
To change a dimension style name in the current drawing 
1   Do one of the following: 
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• On the Settings toolbar, click the Dimension Settings tool  
• Type setdim and then press Enter. 

2   Do one of the following: 
•   Select the dimension style, choose Edit > Rename, type a new name, and then press Enter. 

•   Click the dimension style name you want to change, type a new name, and then press Enter. 

•   Right-click the dimension style name you want to change, and from the shortcut menu, select Rename, 
type a new name, and then press Enter. 

3   To complete the command and return to your drawing, close the window. 
 
 
To copy a dimension style from one drawing to another 
1   Do one of the following: 

• On the Settings toolbar, click the Dimension Settings tool  

• Type setdim and then press Enter. 
 
2   Right-click the dimension style name you want to copy. 

3   From the shortcut menu, select Copy. 
4   In the left pane, select the drawing to which you want to copy the dimension style. 

5   Click the Dimension Styles element for that drawing. 
6   In the right pane, right-click, and then from the shortcut menu, select Paste. 
 

NOTE  Each drawing contains a dimension style named Standard. You cannot delete this dimension style, but 
you can rename it from within the BtoCAD Explorer or modify its properties in the Dimension Settings 
dialog box. 
 
 
 
 
 
 
 
 
 

 


