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No Nonsens inc. LICENSE AGREEMENT

All rights reserved. No part of this book may be 
reproduced or transmitted in any form, by any means, 
electronic or mechanical, including photocopying, 
recording, or by any information storage and retrieval 
system, without written permission from the publisher, 
except for inclusion of brief quotations in a review.

This User Guide is designed to provide information 
about CADpatterns for Illustrator CS. Every effort 
has been made to make this book as complete and 
as accurate as possible, but no warranty of fi tness is 
implied.

The information is provided on an as-is basis. The 
authors and No Nonsens inc. shall have neither 
liability nor responsibility to any person or entity 
with respect to any loss or damages arising from the 
information contained in this User Guide or from the 
use of the discs or programs that may accompany it.

LIMIT OF LIABILITY/DISCLAIMER OF WARRANTY: 
THE PUBLISHER AND THE AUTHOR MAKE NO 
REPRESENTATIONS OR WARRANTIES WITH RESPECT 
TO THE ACCURACY OR COMPLETENESS OF THE 
CONTENTS OF THIS WORK AND SPECIFICALLY 
DISCLAIM ALL WARRANTIES, INCLUDING WITHOUT 
LIMITATION WARRANTIES OF FITNESS FOR A 
PARTICULAR PURPOSE. NO WARRANTY MAY BE 
CREATED OR EXTENDED BY SALES OR PROMOTIONAL 
MATERIALS.
THE ADVICE AND STRATEGIES CONTAINED HEREIN 
MAY NOT BE SUITABLE FOR EVERY SITUATION. THIS 
WORK IS SOLD WITH THE UNDERSTANDING THAT 
THE PUBLISHER IS NOT ENGAGED IN RENDERING 
LEGAL, ACCOUNTING, OR OTHER PROFESSIONAL 
SERVICES. IF PROFESSIONAL ASSISTANCE IS 
REQUIRED, THE SERVICES OF A COMPETENT 
PROFESSIONAL PERSON SHOULD BE SOUGHT. 
NEITHER THE PUBLISHER NOR THE AUTHOR SHALL 
BE LIABLE FOR DAMAGES ARISING HEREFROM. 
THE FACT THAT AN ORGANIZATION OR WEBSITE 
IS REFERRED TO IN THIS WORK AS A CITATION 
AND/OR A POTENTIAL SOURCE OF FURTHER 
INFORMATION DOES NOT MEAN THAT THE AUTHOR 
OR THE PUBLISHER ENDORSES THE INFORMATION 
THE ORGANIZATION OR WEBSITE MAY PROVIDE 
OR RECOMMENDATIONS IT MAY MAKE. FURTHER, 
READERS SHOULD BE AWARE THAT INTERNET 
WEBSITES LISTED IN THIS WORK MAY HAVE 
CHANGED OR DISAPPEARED BETWEEN WHEN THIS 
WORK WAS WRITTEN AND WHEN IT
IS READ.
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Installing the Windows version

Extract the CADpatterns11.zip archive to 
any location you prefer.

Browse to the Adobe Illustrator swatches 
library folder:

Adobe CS
C:\Program Files\Adobe\Adobe Illustrator 
CS\Presets\Swatches

Adobe CS2
C:\Program Files\Adobe\Adobe Illustrator 
CS2\Presets\Swatches

Adobe CS3
C:\Program Files\Adobe\Adobe Illustrator 
CS3\Presets\Swatches

Adobe CS4
C:\Program Files\Adobe\Adobe Illustrator 
CS5\Presets\en_GB\Swatches

Adobe CS5
C:\Program Files\Adobe\Adobe Illustrator 
CS5\Presets\en_GB\Swatches

* for CS4 and CS5 note the “en_GB” part 
in the folder location; this part may differ 
pedending on your installed language.

* not that on x64 computers the “program 
Files” folder is replaced by “Program Files 
(x86)”.

Copy all extracted *.ai fi les (4 fi les in total) 
into the Adobe Illustrator swatches folder.

Next, launch Adobe Illustrator CS.

To access the CADpatterns for Illustrator 
CS libraries, choose Window » Swatch 
Libraries » AutoCAD CADpatterns (or one 
of the other included CADpattern libraries). 

Read the “Opening a custom swatch 
library” chapter for more information.

Installing the Macintosh version

Extract the CADpatterns11.sitx archive to 
any location you prefer.

Browse to the Adobe Illustrator swatches 
library folder:

Adobe CS
HD:applications:Adobe Illustrator 
CS:Presets:Swatches

Adobe CS2
HD:applications:Adobe Illustrator 
CS2:Presets:Swatches

Adobe CS3
HD:applications:Adobe Illustrator 
CS3:Presets:Swatches

Adobe CS4
HD:applications:Adobe Illustrator 
CS4:Presets:en_GB:Swatches

Adobe CS5
HD:applications:Adobe Illustrator 
CS5:Presets:en_GB:Swatches

* for CS4 and CS5 note the “en_GB” part 
in the folder location; this part may differ 
pedending on your installed language.

Copy all extracted *.ai fi les (4 fi les in total) 
into the Adobe Illustrator swatches folder.

Next, launch Adobe Illustrator CS.

To access the CADpatterns for Illustrator 
CS libraries, choose Window » Swatch 
Libraries » AutoCAD CADpatterns (or one 
of the other included CADpattern libraries). 

Read the “Opening a custom swatch 
library” chapter for more information.
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Finding Libraries:

By default, all CAD patterns for Illustrator 
CS libraries are stored in the \Presets\
Swatches\ folder. The \Presets\Swatches\ 
folder can be found within the Illustrator 
root folder (for example: C:\Program Files\
Adobe\Adobe Illustrator CS)

To display the default swatches palette 
choose “Swatches” from the “Window” pull-
down menu.

The “Swatches” palette will appear.

See your Illustrator documentation for 
more information about how to use the 
Swatches Palette.

Opening a custom swatch library:

Choose Open Swatch Library from the 
Swatches palette menu.

From the “Open Swatch Library” menu 
choose one of the CADpatterns for 
Illustrator CS palettes; for example 
“AutoCAD CADpatterns”.

A new palette will appear showing the
“AutoCAD CADpatterns” library.

Notice that additional libraries will always 
appear in new swatch palettes.
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Changing the display of swatches

To change the display of swatches in the 
Swatches palette choose a view option 
from the Swatches palette menu. Availabe 
options are: Small Thumbnail View, Large 
Thumbnail View and List View.

Small Thumbnail View:

Large Thumbnail View:

List View

Making custom palettes persistent

If there are libraries that you often use, 
you can set them to open automatically 
each time you launch Illustrator. Start by 
fi rst opening your frequently-used library 
and then check the Persistent option which 
is found in that library’s palette menu. 
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Using swatches

To apply a CADpattern to an object fi rst 
select the object. Apply the pattern to the 
objects fi ll or stroke by selecting the Fill or 
Stroke in the tools palette. 

Finally single click the pattern of your 
choice in one of the CADpatterns for 
Illustrator CS palettes. The swatch pattern 
is now applied to the selected object(s).

Applied swatches will always fi ll the entire 
area of the object. By default, when 
adjusting the shape of the object, the 
swatch will automatically adjust to the new 
objects area, without distorting the pattern.

Transforming objects

By default object transformations like 
move, rotate and shear will not effect the 
applied swatch pattern as shown in the 
example below:

To include the pattern in the transformation 
enable the “Transform Pattern Tiles” option 
in the Edit » Preferences » General panel.

Swatch patterns will now adjust according 
to the applied transformation.
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Adjusting patterns

To adjust a pattern without affecting 
the object hold down the tilde (~) key. 
First select the object, next choose a 
transformation (rotate, refl ect, scale, 
share) tool. Finally hold down both the shift 
key and the tilde key and drag the pattern. 
The pattern will adjust inside the object 
without changing the object itself.

Important: The borders of the object 
appear to be transformed while dragging 
with the mouse, but when the mouse 
button is released the borders snap back to 
their original confi guration, leaving only the 
pattern transformed. 

The same effect can be achieved by using 
the transform palette.

Also the Rotate,  Refl ect, Scale and Shear 
dialogs (Object » Transform » Rotate) have 
checkboxes to either effect the object, the 
pattern or both.

Adjusting pattern colors

To color or otherwise customize swatch 
patterns fi rst drag a pattern from the 
library palette onto the artbord. Make sure 
no object is selected while dragging.

Notice the swatch pattern in the above 
example contains two boxes. The outer 
box is the object’s bounding box, used 
for transformations, the inner box is 
transparent (both fi ll and stroke) and is 
used to tile the pattern seamless.

Next, ungroup the pattern by choosing 
Object » Ungroup while the object is still 
selected.

Select the objects to colorize, be careful 
not to select the inner box.

Apply fi ll and stroke colors to the selected 
objects. Deselect all objects to preview the 
result.
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Make sure the transparent inner box is 
still the most backwards object. If not, the 
pattern will not tile correctly.

Finally reselect all the objects including the 
inner bounding box and drag the selected 
objects to the swatches palette. Notice 
that it is not possible to add or replace 
swatches in the pre-defi ned CADpattern 
palettes, new swatches can only be added 
to the default swatches palette. See 
chapter “creating libraries” for additional 
information.

A new customized swatch is created and 
can be used as a pattern to fi ll other 
objects.

Adjusting background color

To apply a background color to a swatch 
pattern fi rst drag the pattern from the 
library palette onto the artboard. Make sure 
no object is selected while dragging.

Next, ungroup the pattern by choosing 
Object » Ungroup while the object is still 
selected.

If preferred, apply color to the pattern 
objects as described in the previous 
chapter. This step is not necessary if only a 
background color is needed. 

Because the patterns transparent box 
is needed to tile the pattern seamless a 
copy of this box is required to apply the 
background color. Select the transparent 
(outer) box, make sure no other objects 
are selected and choose Object » Transform 
» Move. The Move dialog appears.
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Type 0 for both horizontal and vertical 
position, next choose copy. A new 
transparent box is created on the same 
location as the original box.

Apply a fi ll color to the selected box, keep 
the stroke transparent.

To create a new swatch from this adjusted 
pattern the transparent box needs to be 
the most backwards object. Select both 
boxes by using a selection window.
Now both boxes are selected. Deselect the 
fi lled box by clicking on the fi ll color while 
holding down the shift key.

Send the selected transparent box to the 
background by choosing Object » Arrange 
» Send to Back.

Finally reselect all the object including the 
transparent box and drag the selected 
objects to the swatches palette. Notice that 
it is not possible to add or replace swatches 
in the pre-defi ned CADpattern palettes, 
new swatches can only be added to the 
default swatches palette. 

See chapter “creating libraries” for 
additional information.
A new customized swatch is created and 
can be used as a pattern to fi ll other 
objects.
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Closing separate lines

To apply a fi ll color to an Illustrator object 
at least two lines of the object should be 
connected (joined). It is not possible to 
apply a fi ll color to two separated lines.

By ungrouping CADpattern patterns for 
editing or for applying color, line objects 
can become separated. It is necessary to 
join these lines together before applying 
colors.

The image below shows a separated 
rectangle with one edge selected.

To join these lines, fi rst select a single 
corner by dragging a selection window by 
using the Direct Selection Tool.

Now the two line corner points are 
selected.

Next choose Object » Path » Join. The Join 
dialog appears.

Choose Smooth for Points and click OK. 
The two lines are now joined to a single 
line.

The Join option is also available in the pop-
up menu. To show the pop-up menu, right-
click on the selected corner points.

Repeat this step for the other corner points 
and all lines are joined together to a single 
rectangle.
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Creating custom libraries

To create a custom library, fi rst remove 
all unwanted swatches from the default 
swatches palette. Select the unwanted 
swatches and choose Delete Swatch from 
the palette dialog menu.

Choose Yes to remove the Swatches.

Add new swatches or swatches from other 
palettes to the default swatches palette, 
next choose Save Swatch Library.

The swatch library is now saved and can be 
used for other drawings.

For information about how to open a 
customized swatch library see the “Opening 
a custom swatch library” chapter.
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Renaming swatches

Swatches can only be renamed in the 
default swatches palette. To rename a 
swatch, fi rst select to swatch, next choose 
Swatch Options from the Swatches Palette 
menu.

Type in the new name for the selected 
swatch.

Click OK, the swatch new name appears in 
the swatches palette.
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