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Abstract

Data Visualization is a tool for importing, displaying and exporting
data. This application operates on already prepared data and its goal is to
display it.

It can be combined with almost any database or any application able to
export its data into files. If the report is a table of some columns and rows,
then Data Visualization is a perfect tool to create ASAP a nicely looking
report.

For end users it’s much more useful some kind of PDF or HTML document
with text formatting, company logo, page numbers etc. than a raw text. This
application allows users to prepare the data layout in an easy way and to
export immediately the result to any format needed.
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1 Three phase logic
Generally there are 3 phases:

Data import In this phase users retrieve data from databases by writing
an SQL query or by importing data from external files.

Template creation In this phase users configure the report layout. Once
the template is created it can be saved and used several times.

Final report (preview) In this phase users behold the final read-only re-
port containing formatted data which can be saved to file using an
export method or directly printed from the preview.

In the last phase formatted data is combined into the final report which
usually consists of several pages and contains all elements configured in the
previous phases. Users customize the layout and see how it looks combined
with imported data. If something has to be modified, there is no need to
restart: the Preview window can be closed and a new report can be generated
later using a different layout. Templates can be reused lots of times with
different data. It’s very useful to create for example a company template
with its logo and the copyright information, save it and use it several times.
The best way is to create and save each report type and reuse it afterwards.
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2 Document structure
The document structure is simple - see image 1.

P a g e  h e a d e r

P a g e  f o o t e r

D a t a

T a b l e  h e a d e r

R e p o r t  h e a d e r

R e p o r t  f o o t e r

V i s i b l e  o n  e v e r y  p a g e

V i s i b l e  o n l y  o n  t h e  f i r s t  p a g e

V i s i b l e  o n l y  o n  t h e  l a s t  p a g e

R e p o r t  s t r u c t u r e :

Figure 1: Document structure.
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3 Data
The data for this application can come from external files or from a database:

1. CSV (Comma Separated Values) file,

2. XLS (Microsoft Office Excel Workbook) file,

3. XLSX (Microsoft Office Excel Workbook 2007) file,

4. ODS (OpenDocument Spreadsheet) file,

5. XML (eXtensible Markup Language) file,

6. database.

If no data is imported, the application will use randomly generated place-
holder.

3.1 Data import

3.1.1 Importing from external files

Data can be imported from CSV (with custom delimiters), XLS(X), XML
and ODS files. In the CSV import dialog the delimiter can be changed; new
delimiters can be added as well. After changing a delimiter the data preview
is refreshed so that users can verify if the data are imported correctly. Once
data are imported, it’s not visible in the template, but they will be used
during the report creation. Supported XLS formats are Microsoft Excel 95,
97, 2000, XP and 2003. Supported XLSX format is Microsoft Excel 2007
and higher.

For importing data from CSV files, users can either choose from menu
Tools→ Import data from→ CSV or click on the Import CSV button or use
the Ctrl - F keyboard shortcut. After choosing the CSV file, the delimiter
might have changed (users can double-check this in the data table preview).
For importing data from XLS files, users can either choose from menu Tools
→ Import data from → XLS or click on the Import XLS button or use the
Ctrl - I keyboard shortcut.

3.1.2 Importing from databases

For importing data from a database, first of all a connection must be set. In
order to configure it, following fields must be filled:

• server address,
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Figure 2: CSV import dialog running on Windows XP.

Figure 3: Data flow.
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• database name,

• port (in case of setting the port number to 0 - default port will be
used),

• user name,

• password,

• database type (for example Oracle).

Once the connection has been created, it may be tested (using the Test
button) and used to perform a Select query. The query might also be loaded
from an external file or be pasted into the dialog. There is a simple keyword
highlighting which helps users to write the proper query. The Code Assist
(which helps to complete a table or a view name) can be triggered by using
the Ctrl + Space shortcut. In order to find out what are the tables, views
and columns in the connected DB, press the DB browser button. The DB
Browser window shows all user (non-system) tables and views. There is
the possibility to see all columns (with their names and SQL types) for a
given table or view and to copy them to the clipboard. Table and view data
preview is also available. Following databases are supported:

• OracleTM10g or higher,

• MySQLTM4.x or higher,

• PostgreSQLTM7.x or higher,

• FirebirdTM1.x or higher,

• InterbaseTM6.x or higher,

• Microsoft SQL ServerTM2000, 2005 and 2008,

• IBM DB2 TM8.x or higher,

• SQLiteTM3.x or higher,

• Sybase SQL AnywhereTM12.x or higher,

• Sybase Adaptive Server EnterpriseTM15 or higher,

• HyperSQLTM,

• Apache DerbyTM,
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Figure 4: Importing data from a database.

• MariaDBTM,

• Amazon SimpleDBTM,

• VoltDBTM.

For importing data from a database, use the Ctrl - K keyboard shortcut
or go to the menu Tools → Import data from → Data base.

Security There are two major questions about database security in third
party software contexts:

1. Can database data be damaged by third party software?

2. Are connections from third party software secure?

Data Visualization answers positively both questions.

1. Data Visualization is designed to perform SELECT statements only so
it does not modify data. Other SQL statements like UPDATE or INSERT
are simply not allowed and will fail. Consequently the first answer is
Yes.
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2. Of course in order to use a database connection details like user name
and password are necessary, but there is an option that allows the end
user to decide whether to store the password or not. If stored, the
password is encrypted so the second answer is Yes.

Browsing DB Once we have a working DB connection we can browse
items like:

1. tables,

2. views,

3. table and view columns with SQL types,

4. supported functions: system, string and numerical,

5. procedures.
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4 Template creation

4.1 Objects

There are varied object types that can be used to create report templates:

• text,

• image,

• data table.

The data table object is always just one and cannot be removed. All other
objects can be as many as users want. In order to edit objects’ contents, right-
click on the object and choose the option from the popup. All objects have
the Area property that may be also changed using the popup menu. The Fit
to grid option helps aligning objects without changing their area explicitly.
It’s possible to fit to grid all objects (right-click on the editor background
and choose Fit all to grid option). Each object has a name which isn’t
however displayed in the final report; it’s just used to identify it univocally
when using the Copy from option. Such option might be used to copy some
object properties into the selected object. All objects above the data table
are considered page header and all those below are considered page footer
(see image 1).

4.1.1 Text objects

Text objects contain formatted text. In order to modify a text right-click
on the object and choose the Change text option or double click on it. In
order to change formatting use the Properties option. In order to copy the
objects’ settings right-click on the destination and choose Copy from. The
list of available fonts depends on the user’s operating system.

4.1.2 Image objects

Image objects contain images. In order to set an image right-click on the
object and choose the Change image option or double click on it. Among
supported image formats there are PNG, GIF, BMP and JPEG. In order
to see image details right-click on it and choose Image details. All image
objects can be copied to Clipboard or to file. In order to do it right-click on
the object and choose the Copy to option.
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4.1.3 Table objects

Table objects contain formatted data. In order to change formatting use the
Properties option. In order to change column text or formatting right-click
on the column header and choose the specific option. Column width can be
edited (double clicking on headers). In order to change the grid properties
right-click on the table body and choose Grid properties.

4.1.4 Report header

The report header is a report part visible only on the first page and can be
edited in the report header tab. Text and image objects can be added and
also report header width and height header can be adjusted in its popup
menu.

4.1.5 Report footer

The report header is a report part visible only on the last page and can be
edited in the report footer tab. Text and image objects can be added and
also report footer width and height can be adjusted in its popup menu.

4.2 Clipboard integration

The use of the Ctrl - V keyboard shortcut allows the automatic creation of:

1. a new text object (if the system clipboard contains any text),

2. a new image object (if the system clipboard contains any image).

New objects are added to the current tab. All text fields in the application
contain right-click popup menus allowing system clipboard operations like
copy, cut and paste. All image objects can be copied to clipboard as well.

4.3 Saving and loading

Templates can be saved as files with *.tpl extension. In order to save a
template click on the Save button or go to the menu File → Save or use the
Ctrl-S keyboard shortcut. In order to load a template do it similarly. All
external resources like images are stored in the tpl file.
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Figure 5: Template designer running on Windows 7.
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4.4 Column Manager

The Column Manager is a tool which allows users to add, remove and modify
report columns. Each column header and width (%) can be adjusted. The
maximum allowed number of columns is 16. In order to launch the Column
Manager go to the menu Tools → Column Manager or right-click on the
report table and choose Column Manager.

4.5 Page numbers

Page numbers might be either on the upper or on the lower right corner.
Text formatting, i.e. font type, font size, color and style can be customized.
It’s possible to choose if there should be a page number displayed on the first
page. In order to edit the page number position go to the menu Edit → Page
numbers.

4.6 Default properties

Default properties contain all the text formatting, color information etc.
used to create new objects. If a new text object is added, all its properties
are copied from the default ones. It’s a good practice and time-saving to
configure default properties at the beginning. They are very useful when all
created templates are made according to a specific standard, for example if
all components have the same font or the same background color.

4.7 Z order

All components have a Z order property (by default it’s 0). This property
is an integer between 0 and 100 corresponding with Z variable (depth). The
lower it is, the deeper the component will be. So, for example, let’s say
that the component A has Z order property = 10 and another component
B has 25. In this case, if they overlap each other, the component B will be
placed over the component A. The value of this property might be modified
by right-clicking on the specific component and choosing Set Z Order.

4.8 Variables

Variables can be used in text components; their values are calculated while
report is being generated. Note that all variables begin with the $ character.
The list of all available variables can be seen in figure 3. Values of following
variables: $author, $title, $subtitle, $major, $minor and $description
may be modified in the Template info window.
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Figure 6: Column Manager running on Windows XP.
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Variable name(s) Value
$date or $today Current date
$now or $time Current time

$author Author
$title Title

$subtitle Subtitle
$major Major version
$minor Minor version

$description Description
$rows Number of rows

Figure 7: Available variables.

4.9 Object Browser

The Object Browser is a tool for viewing all components in a report tem-
plate. It’s divided into two panels; the left panel contains an object tree
and the right one contains the details of the selected object. The component
information displayed contains:

• name

• type

• Z order

• specific component details (depending on component type)

In order to run the Object Browser go to the menu Tools → Object Browser.

4.10 Recycled bin

The Recycled bin is a container storing all removed components. Components
in the Recycled bin can be restored or removed forever. In order to enter
the Recycled Bin click on the Recycled bin button or press the Ctrl - R
keyboard shortcut.

4.11 Grid

The grid helps to visually adjust components’ location and size. Of course
it’s never as precise as adjusting the specific location inserting numeric pa-
rameters; it rather helps to verify if any components are not aligned correctly
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Figure 8: Object Browser running on Kubuntu 9.04 and KDE 4.2.2.

with others. The grid might be turned on/off by clicking on the Grid check
box in the upper right corner of the template creation window.

4.12 Template Info

The Template info contains data like author, title, subtitle, description and
major/minor version. The values once put here may be used via variables
like $author, $title, $subtitle, $description, $major and $minor. In
order to edit the Template info go to the menu Tools → Template Info or
use the Ctrl + P keyboard shortcut.
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Figure 9: Recycled bin running on Kubuntu 9.04 and KDE 4.2.2.
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5 Preview
In order to generate a report click on the Generate report button. The report
preview is the sum of the configured template and the imported data (see
image 1). In order to browse use the First page, Previous page, Next page and
Last page buttons. There is also a zoom feature available. The margin in the
preview may be enabled/disabled and this does not influence the exported
documents.

5.1 Export

There are many export methods available in the Preview menu like:

• PDF (Portable Document Format),

• XML (eXtensible Markup Language),

• CSV (Comma Separated Values),

• RTF (Rich Text Format),

• XLS (Microsoft Office Excel Workbook),

• XLSX (Microsoft Office Excel Workbook 2007),

• TXT (Plain text),

• HTML (HyperText Markup Language) with CSS (Cascading Style Sheets),

• MATLAB (MATLAB m File),

• DOCX (Microsoft Word 2007),

• LATEX,

• SQL statements,

• YAML (YAML Ain’t Markup Language),

• JSON (JavaScript Object Notation),

• DocBook,

• Markdown,

• Clipboard.
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Figure 10: Preview running on MacOS
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Exported PDF files are of course fully searchable and can be protected by
password. Export settings like encoding, new line delimiters, version, etc.
depend on the chosen format. Some export methods like MATLAB or YAML
support only data without any formatting. Data Visualization tries to create
documents as similar as possible to the layout chosen by user and also gives
a wide parameter choice.

5.2 Printing

In order to print a report go to the menu File → Print, where the printers
dialog will be shown. This dialog depends on user’s operating system.

6 Batch
This tool allows users to:

1. import lots of CSV and XLS(X) files

2. create lots of reports containing imported data and current report tem-
plates

3. export final reports to lots of formats (the ones available also for the
standard export feature)

For example you can import 200 (let’s say 100 CSV and 100 XLS ) files to the
current report template and then export it to PDF, XML and XLS creating
in few minutes 600 files automatically. This option should be used when lots
of documents with the same layout, but different data, need to be created.
As the result folder might contain a huge number of files, the "Zip results"
option is recommended. If this option is enabled, all results will be zipped
into one zip file. The names of imported files might have duplicates - in
the export results the duplicates will be automatically renamed by adding
numbers at the end of the filename. If some imported files don’t match
the current template dimension (number of columns), they will not be used.
When the batch is complete, specific information for each file processed is
displayed, i.e. if:

• the import succeeded,

• the export succeeded for each chosen export method.

There is also the possibility to import data from a database by selecting
*.sql files containing queries. In order to run a Batch click on the Batch
button or go to the menu Tools → Batch.
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Figure 11: Batch running on Mac.
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7 Application Localization
Currently supported languages there are:

• English,

• Polish,

• Spanish,

• Italian,

• German,

• French,

• Czech,

• Portuguese.

Chosen language influences only the translations of all labels in the Data
Visualization application. It doesn’t influence neither the date format, nor
the hour format, nor decimal separators etc.. These formats are fixed and
they don’t depend on anything.
In order to change the language go to the Language menu. The application
should be restarted in order to apply language changes.
More languages and localized date, hour and numeric format support will be
added in future versions.
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8 Keyboard shortcuts

Shortcut Action
Ctrl - I Import data from XLS
Ctrl - A Import data from XLSX
Ctrl - B Import data from ODS
Ctrl - F Import data from CSV
Ctrl - K Import data from database
Ctrl - S Save template
Ctrl - L Load template
Ctrl - G Generate report
Ctrl - C Close application
Ctrl - R Recycled bin
Ctrl - G Generate report
Ctrl - D Default properties
Ctrl - M System info
Ctrl - J Environment info
Ctrl - H Show logs
Ctrl - O Documentation
Ctrl - E Edit page numbers
Ctrl - T Show tips
Ctrl - N Column Manager
Ctrl - Y Batch
Ctrl - W Show data
Ctrl - T Reset template
Ctrl - M New image object
Ctrl - X New text object
Ctrl - P Template info

Figure 12: Template phase shortcuts.
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Shortcut Action
+ Zoom in
- Zoom out
* 100% zoom

Ctrl - P Print report
P or Ctrl-Minus Previous page

F or Ctrl-F First page
N or Ctrl-N Next page
L or Ctrl-L Last page
Ctrl - H Export to HTML
Ctrl - D Export to PDF
Ctrl - X Export to XLS
Ctrl - S Export to XLSX
Ctrl - H Export to HTML
Ctrl - V Export to CSV
Ctrl - M Export to XML
Ctrl - R Export to RTF
Ctrl - H Export to HTML
Ctrl - T Export to TXT
Ctrl - B Export to MATLAB
Ctrl - C Close report preview
Ctrl - T Show tips
Ctrl - A About
Ctrl - M System info
Ctrl - H Show logs
Ctrl - O Documentation

Figure 13: Preview phase shortcuts.
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9 Requirements

9.1 Software

Since Data Visualization is written in Java, it needs a 32 or 64 bit Java
Runtime Environment (version 7 or higher) to run. Following operating
systems supported by Oracle’s Java Virtual Machine have been tested:

• Linux with GNOME or KDE installed,

• Microsoft Windows 2000/XP/Vista/2003, 2008 Server, 7 and 8.

• Oracle Solaris 10 or higher with Java Desktop System or CDE desktop
environment,

• Mac OS X or higher.

Both 32 and 64 bit operating systems are supported. Tested Linux dis-
tributions are Kubuntu with KDE and Debian with GNOME. In order to
download the Java Runtime Environment go to following link:
http://www.oracle.com/technetwork/java/javase/downloads/index.html.
In order to see details about Java supported environments go to following
link:
http://www.oracle.com/technetwork/java/javase/system-configurations-135212.
html. In order to read this documentation a PDF viewer has to be installed.

9.2 Hardware

Hardware requirements:

RAM 512 MB or more,

CPU 1 GHz AMD/Intel or faster,

Free disk space at least 100 MB.

10 Bug reporting
In order to report bugs please send the System Info file (Help→ System info)
and the logs (Help→ Show log) to the author’s e-mail address: <adamwitkowski3@gmail.com>.
The up-to-date list of open bugs can be found here:
http://sites.google.com/site/datavisualizationapplication/bug-tracking.

http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.oracle.com/technetwork/java/javase/system-configurations-135212.html
http://www.oracle.com/technetwork/java/javase/system-configurations-135212.html
http://sites.google.com/site/datavisualizationapplication/bug-tracking
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11 Future development
Several new features are scheduled for future Data Visualization versions:

1. more supported languages,

2. more exports supported like: ODS and SVG,

3. more data sources supported like: MongoDB, Neo4j, SQLFire, VoltDB,
Mimer SQL and SmallSQL

4. custom JDBC driver support,

5. data base diagram visualization,

6. charts,

7. lots of GUI improvements.

All suggestions might be sent to the author’s e-mail address:
<adamwitkowski3@gmail.com>. The up-to date list can be found here:
http://sites.google.com/site/datavisualizationapplication/to-dos.

12 Author
Data Visualization is created by AdamWitkowski <adamwitkowski3@gmail.com>.
All rights reserved. Copyright c©2006-2014.

13 The team
The Data Visualization team:

• Adam Witkowski (Project Manager, Developer and Translator),

• Matteo Garaventa (QA Engineer and German Translator),

• Piotr Zema (Developer and Release Engineer),

• Andrzej Witkowski (Portuguese and Spanish Translator),

• Tomasz Rumak (UNIX Admin, Developer and Release Engineer).

More details can be found here:
http://sites.google.com/site/datavisualizationapplication/the-team.

http://sites.google.com/site/datavisualizationapplication/to-dos
http://sites.google.com/site/datavisualizationapplication/the-team
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14 Official website
http://sites.google.com/site/datavisualizationapplication/

15 Notes
All Java and Java-related logos and trademarks are trademarks of Oracle
Corporation. Microsoft Excel is a trademark of the Microsoft Corporation.
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