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Introduction

Thank you for using FileCleaner for Microsoft Word!

Have you ever wished you could quickly and easily clean up common typographical problems in a manuscript without tediously finding and replacing each one? FileCleaner lets you do just that, replacing double spaces with single spaces, changing double returns to single returns, turning underlining to italic, fixing spacing around ellipses, and so on. FileCleaner will save you hours of time while improving the typographical quality of everything you write or edit.

FileCleaner is especially useful to people who are preparing text for typesetting and are using Microsoft Word as a "front end" for such programs as QuarkXPress, PageMaker, or FrameMaker. Editors and typesetters will find it invaluable, and this documentation is geared primarily to them. FileCleaner is also an excellent tool for desktop or electronic publishing, and writers will appreciate being able to clean up common manuscript problems in one fell swoop.

By using FileCleaner, you accept the Terms of Agreement found at the end of this document. The first time you use FileCleaner, the terms of agreement will appear on your screen. Please read them carefully. If you accept the terms, you will be able to use the program. If not, you will not be able to use it.

Macros and Templates

FileCleaner is basically a collection of macros in a template (named Fileclnr.dot). You don’t use this template as you would an ordinary template by attaching it to a document. If you try to do that, you’ll run into problems. Instead, you “add” it to Microsoft Word as a global template or add-in (see installation instructions below).

Because the template contains macros, some virus-checking programs or even Word itself may warn you that the template could contain Word viruses. Please rest assured that it does not. Our macros have been carefully checked and tested to make sure they are safe and usable. To ensure your security, you should download the program directly from our Web site at www.editorium.com.

Please do not rename any of the FileCleaner macros, copy them to another template, or remove them from the FileCleaner template. FileCleaner uses these macros in combination and will not work properly if they have been copied to another template or renamed, or if some of the macros are no longer present.

Installing FileCleaner

To install the program:

1. Unzip (or unstuff) the program files so that they’re all together in a single folder or on your desktop. (If you need software to unzip or unstuff the program, you can download it from www.winzip.com or www.aladdinsys.com.) You cannot install the program by just opening the zip file and double-clicking one of the files.
2. After the files are unzipped, open the file named “Install FileCleaner.dot” in Microsoft Word by clicking File > Open, selecting the file, and clicking the Open button. Do not open the file by double-clicking it outside of Microsoft Word. If you do, you’ll run into problems later.

3. If Word asks if you want to “enable macros” when opening the file, your answer should be yes. Otherwise, the program won’t work. If Word tells you that the macros have been disabled, you’ll need to change your macro security settings and then restart Word before installing. Please see the “Troubleshooting” section at the end of this document for more information.

4. Double-click the large button that says “Double-Click here to Install.” This will install FileCleaner as a global template or add-in, which simply means that the program will be saved to Word’s Startup folder and will thus be available any time you start Word.

5. Restart Word to activate the program and display the FileCleaner menu at the top of your Word window. In Word 2007, the menu will be displayed under Word’s “Add-ins” menu.
If that doesn’t  work, you can install the program manually. With Microsoft Word closed:

1.
On your computer desktop, double-click My Computer. (On a Macintosh, open your hard drive. Then continue with step 5, below.)

2.
At the top of the window that opens, you’ll see a “Tools” menu. Click that, and then click “Folder Options.”

3.
Click the “View” tab and make sure that “Show hidden files and folders” is selected. Then click the OK button.

4.
Back in the window for “My Computer,” double-click your local hard drive, probably “C.”

5.
Open the folders named, consecutively within each other, Documents and Settings > [your name] > Application Data > Microsoft > Word > Startup. (On a Macintosh, open Applications > Microsoft Office > Office > Startup > Word.)

6.
Put the file named “Fileclnr.dot” into the Startup folder (on a Macintosh, into the Startup > Word folder).

7.
Restart Microsoft Word.
Uninstalling FileCleaner

To uninstall the program:

1. Open the file named “Install FileCleaner.dot” in Microsoft Word by clicking File > Open, selecting the template, and clicking the Open button. Do not open the file by double-clicking it outside of Microsoft Word. If you do, you’ll run into problems later.

2. If Word asks if you want to “enable macros” when opening the file, your answer should be yes. Otherwise, the program won’t work. If Word tells you that the macros have been disabled, you’ll need to change your macro security settings in order to use the program. Please see the “Troubleshooting” section of this documentation for more information.

3. Double-click the large button that says “Double-Click here to Uninstall.”

If necessary, you can remove the template manually from Word’s Startup folder:

1.
On your computer desktop, double-click My Computer. (On a Macintosh, open your hard drive. Then continue with step 5, below.)
2.
At the top of the window that opens, you’ll see a “Tools” menu. Click that, and then click “Folder Options.”
3.
Click the “View” tab and make sure that “Show hidden files and folders” is selected. Then click the OK button.

4.
Back in the window for “My Computer,” double-click your local hard drive, probably “C.”
5.
Open the folders named, consecutively within each other, Documents and Settings > [your name] > Application Data > Microsoft > Word > Startup. (On a Macintosh, open Applications > Microsoft Office > Office > Startup > Word.)
6.
Remove the file named “Fileclnr.dot.”
7.
Restart Microsoft Word.

Running FileCleaner

Before running FileCleaner, be sure to back up your documents in case you later change your mind. In addition, try using FileCleaner on some test files until you understand how it works and what it does. Then you'll be prepared for the real thing.

You can use FileCleaner to clean up documents in two different ways:

1. One item at a time. You can do this by clicking the buttons on the FileCleaner Toolbar, which you can activate by selecting Toolbars under the View menu and clicking the FileCleaner checkbox. This is handy for cleaning up problems as you come across them while editing a document. Please note that this type of cleanup affects only the part of the document you are in. For example, if you are in a footnote panel, it will clean up the footnotes. If you are in the main text, that is what will be cleaned up.

2. All items (or several selected items) at once. Do this by selecting FileCleaner under the FileCleaner menu or by pressing the FileCleaner button at the left of the Toolbar. This option is useful for cleaning up all problems at one time. It is very powerful and is probably the one you will use the most. This type of cleanup affects the main text in a document, footnotes and endnotes, and (on a PC but not a Macintosh) headers and footers. It does not, however, clean up annotations.

When you run FileCleaner to clean up all items at once, the program asks if you want to clean up the active document, all open documents, or all documents in a folder. Select the option that suits your needs.

Cleaning Up All Documents in a Folder

Before cleaning up all documents in a folder, copy them to a working folder called something like “Copy.” That will leave your original files intact in case something goes wrong. Also, make sure only the files you want to clean up are in the Copy folder. Then you won't inadvertently clean up, say, some press-ready files that you have spent many hours editing and formatting.

In addition, make sure none of the files is protected or read only. FileCleaner cleans up the files and then saves them. If the files are protected or read only, FileCleaner will not work. You may also run into problems if your files need to be converted into Microsoft Word from a different word-processing format. Please make sure all of your files are in Microsoft Word format before running the program.

If you select the option to clean up all the documents in a folder, FileCleaner presents a dialog box that allows you to select the folder to which you have copied the files to be cleaned (leaving your original files safe in their original folder). After you have carefully selected the Copy folder (don’t get the wrong one!), click the OK button or press ENTER to continue.

When FileCleaner is finished and you have looked through the files to be sure they are cleaned up correctly, you can move them from the Copy folder to your original folder.

Selecting Items to Clean Up

The program will show you a list of items you might want to clean up, and you can check the ones you want to use. Please note the two boxes at the bottom that allow you to clear or select all the items on the list. Also note that the items will be cleaned up in the order in which they appear on the list. This is important because some items will not be cleaned up correctly unless other items have been cleaned up first. For example, you can't dependably clean up spacing around ellipses without first cleaning up multiple spaces. (Also keep this in mind when cleaning up individual items with the toolbar buttons.)

When you are finished selecting the items you want to clean up, click the OK button. FileCleaner will do the job as you requested. When it is done, it will display a message saying "Finished!" Click “OK,” then review your cleaned-up documents. If you change your mind, go back to the original files.

Other Considerations

You may want to run FileCleaner twice: once before you begin editing, and once before you are ready for typesetting or final formatting. Please read the sections entitled "Remove Font Formatting," "Remove Paragraph Formatting," and "Remove Style Formatting" under FileCleaner Options, below, before doing so, however.

Please note that FileCleaner turns off both viewing and marking of revisions while it works.

FileCleaner Options

Here are the various cleaning options FileCleaner provides:

Put Abbreviations in Small Caps

This option puts A.M., P.M., B.C., A.D., B.C.E., and C.E. into small caps, which is how they should appear typographically. Please note that if you abbreviate “chief executive officer” as C.E.O. (with periods) rather than CEO (without periods), this option will put the C.E. into small caps.

Change Underlining to Italics

This option changes text that is underlined into text that is italicized. In the days before word-processing, people used typewriter underlining to indicate text that was to be set in italics. Some writers, even though they are now composing on computer, still continue in that tradition. Underlining, however, should not ordinarily be used in typesetting, and this option allows you to turn it into italics as it should be.

Change Raised Text (3 Points) to Superscript

This option changes text that is raised by three points into superscript. The point of this is that Word documents that have been converted from WordPerfect often have footnote numbers that are raised rather than superscript. This option fixes the problem.

Delete Extraneous Tabs

The proper way to set paragraph indentation is with formatting in a style, not with a tab. That means all tabs at the beginnings of paragraphs should be deleted. This option does the trick. It also replaces multiple tabs inside paragraphs with single tabs so tabular formatting can be done correctly by adjusting tab settings. Warning: If an author has used tabs to do specialized formatting of tables or diagrams, you'll want to use this option with caution.

Replace Multiple Spaces with Single Spaces

Your high-school typing teacher probably told you to put double spaces after the end of each sentence to make your typing "easier to read." Actually, this is a typographical abomination that must be cleaned up before a document is typeset. This option turns any combination of spaces into one space. Warning: If an author has used spaces to do specialized formatting of tables or diagrams, you'll want to use this option with caution.

Delete Spaces around Returns

Spaces around carriage returns are invisible to the eye, but they cause various typographical problems. This option gets rid of them. Because Word does not permit the deletion of returns after footnotes and endnotes, this option does not work with notes.

Replace Multiple Returns with Single Returns

Ordinarily, the proper way to set extra leading between paragraphs or after headings is with formatting in a style, not with extra carriage returns. This option turns any combination of returns into a single return. Because Word does not permit the deletion of returns after footnotes and endnotes, this option does not work with notes. Warning: If an author has used multiple returns to indicate special formatting, you'll want to use this option with caution.

Fix Spacing around Ellipses

Authors have numerous ways of typing ellipses. Some use the horrid little ellipses "character" available in some symbol fonts. Others type three periods in a row with no spacing in between. And there are many other variations. This option fixes them all, with three periods separated by spaces. (The spaces after the first two ellipsis points are nonbreaking so the ellipsis points won't break at the end of a line.)

Change Straight Quotation Marks to Curly Ones

If you are editing a file that contains "straight," old-fashioned quotation marks and apostrophes as found on a typewriter, you can turn them into typographically correct "curly" marks by using this option, which will also activate Word's Autoformat option of turning straight quotation marks to curly ones as you type.

This option also turns single quotation marks at the beginning of certain words into apostrophes. These words are ’til, ’tis, ’tisn’t, ’twas, ’twasn’t, ’twould, ’twouldn’t, and ’em. The same is true of single quotation marks in front of numbers, such as ’99. Except for these exceptions, this option will turn apostrophes at the beginning of words into single quotation marks, which is almost always what they should be.

There is also a macro that does precisely the opposite of this option, turning curly marks into straight ones and turning off the Autoformat option. Its name is FixCurlyQuotationMarks. You can run it under Tools, Macros, and you'll find it especially useful if you are creating Help files.

Fix Commas and Periods outside Quotation Marks

Typographically, commas and periods should be "inside" (to the left of) closing quotation marks. Why? Because they look funny hanging out there all by themselves. This option puts them where they belong.

Fix Punctuation Marks outside Italics

Punctuation should usually be typeset in the character style of the text that precedes it. For example, if a word set in italic type is followed by a question mark, the question mark, too, should be set in italic type. This option makes it so for periods, commas, colons, semicolons, question marks, and exclamation points.

Change Double Hyphens to Em Dashes

Em dashes are used for various purposes, such as setting off an illustrative element from the rest of the sentence. Many authors use double hyphens to indicate em dashes--like this. This option turns each set of hyphens into the dash it should be.

Change Hyphens between Numerals to En Dashes

En dashes are used primarily to indicate inclusive numbers, as in an index. Many authors use hyphens to serve the same purpose, like this: 145-46. This option changes those hyphens into typographically correct en dashes.

Delete Spaces around Dashes

Some authors think it looks nice to leave spaces around both em and en dashes. It doesn't. This option removes those spaces.

Change Ells Used as Ones to Ones

Remember when typewriters didn't even have a character for the numeral one? The ell did double duty, probably to keep the number of keys to a minimum. Now, decades later, some authors still type ells for ones, creating a typographic nightmare. This option fixes all such problems while leaving the real ells intact.

Change Os Used as Zeroes to Zeroes

This problem is similar to the previous one. Some authors type an O when they should type a zero, but typographically the two characters are not the same. This option fixes the mistake.

Remove Font Formatting

Authors often go to great lengths to format their documents using various fonts, point sizes, paragraph formats, and so on. What they don't realize is that such formatting, nice as it may look to them, is nowhere near the look you or your designer will specify. In fact, their formatting usually just gets in the way, making editing and typesetting more difficult than it should be.

This option removes all directly applied font formatting, such as Times New Roman 12 point. However, it retains certain character formatting (bold, italic, underline, word underline, superscript, subscript, small caps, all caps, strikethrough, and hidden) as well as paragraph styles, such as Normal and Heading 1. This leaves you with a document in which you can modify the paragraph styles to format the document properly.

Remove Paragraph Formatting

This option removes all directly applied paragraph formatting, such as Centered or Justified, again so you can adjust paragraph formatting by modifying styles.

Remove Style Formatting

This option applies the Normal style to the entire document, wiping out any other paragraph styles. Warning: If an author has used styles properly to mark various text levels, you may not want to use this option. Also, if you have used styles to format a document and want to retain them, do not use this option.
Registering FileCleaner

If you like FileCleaner and plan to continue using it, you should purchase a license to do so. If you don't, your copy of the program is for evaluation purposes only, and it will stop working after 45 days or 1,000 uses, whichever comes first. After you purchase a license to use the program, we'll send you a password that will unlock the program to run without limitation on time or use.

The terms of your license prohibit you from giving your program password to someone else or using it on someone else's computer. However, you may use the password on up to three of your own computers. For example, you could install FileCleaner and use your password on your computer at work, your computer at home, and your laptop. However, you may run the program on only one of your computers at a time. If you need to run the program on more than one computer at a time (for example, for use by a family member or employee), you must purchase another license and get another password for the program. This is the honest and legal thing to do. Besides that, we’re a small company and need your support. Thanks for your cooperation.

Here are the prices for a program license, but these are subject to change without notice:

1 user: $29.95

2-10 users: $19.95

11-49 users: $18.95

50+ users: $17.95

Getting a Password

Here’s how to purchase a program license so you can get your password:

1. Click the FileCleaner menu item at the top of your Word window.

2. Click the “Register FileCleaner” menu item.

You’ll be presented with two options:

1. Get a password for this computer.

2. Enter the password for this computer.

Click option 1, “Get a password for this computer.” Then click “OK.”

You’ll be presented with two more options:

1. Register on the Internet (at www.editorium.com).

2. Register by mail.

Click the option that meets your needs and follow the instructions on your screen. Registering on the Internet offers some distinct advantages:

1. You’ll receive your password automatically by return email as soon as your payment is processed. If you’re paying by credit card, you’ll receive your password almost immediately. Just check your email as soon as your online registration is complete.

2. You can make your payment in several different forms: credit card, check, or money order. If you don’t pay with a credit card, however, you won’t receive your password until after we receive your payment.

3. You can make your payment in several different ways: on our secure online order form, by fax, or over the phone.

If you're interested in using a purchase order, please let us know by emailing sales@editorium.com.

If you don’t have access to the Internet, you can still register by postal mail. In that case, we’ll send your password by email (if you have it) or postal mail after we receive your check or money order and your registration form. If you’re registering by mail, the program will create a registration form in Microsoft Word. Please fill out the form, using your cursor keys to move from item to item. Then print the form and mail it to the address at the top of the form.

Using Your Password

Once you’ve received your password from the Editorium, you’ll need to enter it into the FileCleaner program. To do so:

1. Click the “FileCleaner” menu item at the top of the Word screen.

2. Click the “Register” menu item.

3. Click “Enter the password for this computer.” Then click “OK.”

The password entry box will appear on your screen. Carefully type the password into the box labeled “Enter your password.”

If you have a valid password and type it correctly, the program will tell you that your registration was successful. After that, the program will run without limitation on time or use.

Thanks for your support!

Troubleshooting

Problem: When you try to open the file to install the program, Microsoft Word tells you that “The macros in this project are disabled . . .”

Solution: Microsoft Word’s macro virus protection is enabled or set to a high level of security. To change this:

In Word 2007 (PC):

1. Click the round Office button at the upper left of your Word window.

2. Click “Word Options”.

3. Click the “Trust Center” button on the left.

4. Click the “Trust Center Settings” button on the right.

5. Select “Enable all macros,” which you should change back to your previous setting after the installation is finished.

6. Click the OK button.

7. Click the next OK button to close the Word Options dialog.

In Word 2004 (Macintosh):

1. Click the “Word” menu.

2. Click “Preferences.” 

3. Click “Security.”

4. Uncheck “Warn before opening a file that contains macros.”

5. Click the OK button.

In Word 2002/XP or 2003 (PC):

1. Click the “Tools” menu.

2. Click “Options.”

3. Click the “Security” tab.

4. Click the “Macro Security” button (on the lower right).

5. Click the “Security Level” tab if it’s not already active.

6. Set your security level to medium and click the OK button.

7. Click the next OK button to close the Options dialog.

In Word 2001 (Macintosh):

1. Click the “Edit” menu.

2. Click “Preferences.”

3. Click the “General” tab if it’s not already active.

4. Uncheck “Macro virus protection.”

5. Click the OK button.

In Word 2000 (PC):

1. Click the “Tools” menu.

2. Click “Macro.”

3. Click “Security.”

4. Click the “Security Level” tab if it’s not already active.

5. Set your security level to medium and click the OK button.

In Word 98 (Macintosh):

1. Click the “Tools” menu.

2. Click “Preferences.”

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

In Word 97 (PC):

1. Click the “Tools” menu.

2. Click “Options”.

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

After installing the program, you may want to reset your security settings to their previous state. If you don’t (in Word 2000 through 2003 on PC), any time you open a document or template that includes macros, Word will give you the choice of whether to disable or enable macros. If the document or template isn’t supposed to have macros in it, you should click the “Disable Macros” button, because the macros could be a virus. If the document or template is supposed to have macros and comes from a source you know is reliable, click the “Enable Macros” button so you can run the macros.

In other versions of Word, you don’t have these options. Macro virus protection is either on or off. Before turning it off permanently you may want to read more about it in Word’s Help file or check with your system administrator.

If you need more help, please send an email message to support@editorium.com.

Problem: FileCleaner has been running for hours while cleaning just a few short documents.

Solution: Press the Escape key to stop the program. Look at the cursor position in the open document to see if you can figure out what may be causing the problem. If you can, fix the problem before running FileCleaner again. Also, check the documents after the problem document to see if they have the same problem.

Problem: Microsoft Word crashes at some point when you’re using FileCleaner to clean all open documents or all documents in a folder.

Solution: Some of your documents may be corrupt. You can identify a document that caused the crash by reading its name in the bar at the top of the Word window when the program crashes. If possible, open the document, copy all of its text, and paste the text into a new document.

Any Questions?

We hope you find FileCleaner to be immensely useful. If you have any questions or comments, please let us know.

support@editorium.com

www.editorium.com

The Editorium provides word-processing tools for editors, writers, and other publishing professionals. If you like FileCleaner, you may be interested in these other products from the Editorium:

Editor’s ToolKit Plus includes Editor’s ToolKit, FileCleaner, NoteStripper, and QuarkConverter.

Editor’s ToolKit provides powerful tools for copyediting in Microsoft Word.

QuarkConverter converts Word documents into XPressTag files for import into QuarkXPress.

NoteStripper strips footnotes and endnotes to the end of a document as numbered text.

MegaReplacer finds and replaces multiple words, phrases, and even styles in multiple documents.

You can download fully functioning evaluation copies of these programs free of charge from the Editorium's site on the World Wide Web at www.editorium.com.

This documentation and the FileCleaner software are copyright © 1996, 1999, 2001 by the Editorium. All rights are reserved. Editor’s ToolKit Plus, Editor’s ToolKit, NoteStripper, MegaReplacer, FileCleaner, and Editorium are trademarks of the Editorium.

All trademarks mentioned in this documentation or the program are acknowledged as trademarks of their owners.

Terms of Agreement

By using FileCleaner, you agree to these terms:

LICENSE AGREEMENT

The FileCleaner software and its documentation (collectively the Software) are protected by the United States copyright laws and international treaties and are owned solely and entirely by the Editorium.

You (the licensee) may run the Software on up to three computers (but only on one at a time) during its evaluation period and (if you purchase a license to do so) after that. You may not copy or sell the Software for commercial gain.

You may freely transfer copies of the Software to others for evaluation. You may NOT let someone else use your password for the Software or rent or lease your license to run it, but you may transfer the license to someone else who accepts this agreement.

You may not modify, reverse engineer, decompile, disassemble, unencrypt, or create derivative works from the Software. You may not use the Software in any manner that infringes the intellectual property or other rights of another party.

DISCLAIMER OF WARRANTY AND LIABILITY

The Editorium disclaims all warranties on the Software, expressed or implied, including but not limited to warranties of merchantability and fitness for any particular application, use, or purpose. You use it at your own risk.
Under no circumstances, including its own negligence, shall the Editorium or its suppliers be liable for any special, incidental, or consequential damages or loss that result from the use of, or the inability to use, the Software.

This agreement shall be construed, interpreted, and governed by the laws of the State of Utah in the United States of America.

